Qt Creator 3.0.1 - remote debugging --> SIGILL



  • Hello,

    I'm using Qt 5.2.1 and Qt Creator 3.0.1 on Ubuntu 12.04 64-bit host.
    If I try to remote debug my application on the freescale i.mx6 board (armv7l) I immediately get a "Illegal instruction"-Signal (SIGILL). The deployment works and I can run the application.

    I tried to connect the gdb-server and gdb manually, this works perfect. Because of that I think it's a bug in Qt Creator.

    Best regards
    okieh



  • @okieh

    You can check for bug reports on JIRA.
    You could also install the newer version of Qt creator from download page. Qt creator is already at version 3.4.1.



  • @koahnig

    I downloaded the latest version of Qt Creator, but now I get another error:

    Warning: No kit 'qt.521.gcc_64.essentials_kit' found. Continuing.
    Warning: Abbruch auf Nutzeranforderung...
    (no active run control)
    Warning: HANDLE RUNCONTROL START FAILED (no active run control)
    Warning: State changed from EngineSetupFailed(2) to DebuggerFinished(23) [master] (no active run control)
    Warning: (gdb) (no active run control)
    Warning: QUIT DEBUGGER REQUESTED IN STATE 23 (no active run control)
    Warning: 15^done (no active run control)
    Warning: (gdb) (no active run control)
    Warning: 16^done (no active run control)
    Warning: (gdb) (no active run control)



  • @okieh

    As it looks to me the installation of Qt 5.2.1 is broken. If possible you should also install the newest version of Qt libs IMHO.

    However, from personal experience it might be also worthwhile to update your Ubuntu. I am operating a server with Ubuntu 12.04 and had quite a bit of trouble in connection Qt 5 there. Luckily the admin there, "some" version (5.0 or 5.1) to work at least moderately.
    On Ubuntu 14.04 on my desktop everything worked like a charm.
    Finally I like to state that I am developing on Windows. Therefore, my Linux knowledge is limited as well.