QWebEngine - Deploy problem (QWebProcess.exe)



  • I'm trying to deploy my software that is now using QWebEngine.
    I get this error on other computers :
    QWebEngineProcess not found in /..../[somepath]/QtWebEngineProcess.exe
    I don't know why it's checking in this path, the path is not good and is the path used by the compiling PC. I copied the QWebEngineProcess.exe and QWebProcess.exe manually inside /release but it's still checking for this path..

    https://www.dropbox.com/s/guz5z786e4y3k4z/errorWebEngine.png?dl=0

    QWebView was straightforward to deploy, copy the dll inside release and it worked. but for QWebEngine, seems like I'm missing something

    Edit:
    Solved using this receipe..
    1- Create a qt.conf file in /release
    2- add this text :
    [Paths]
    Prefix=.
    Data=.
    3- Copy QWebEngineProcess.exe and QWebProcess.exe in /release
    4- Copy "icudtl.dat" inside /release
    5- Copy "qtwebengine_resources.pak" inside /release
    6- Don't forget to include theses files in your setup packages



  • is not useful;
    the qwebengineprocess.exe debug log is
    [0326/201052:WARNING:resource_bundle.cc(286)] locale_file_path.empty()



  • @yubb

    You're having problem deploying too?
    I guess they should make a wiki/guide with clear instructions on how to deploy it. It's a bit complex ATM and not automated, I went back to using QWebKit for my browser until it's easier. Good luck


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.