Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Symbian and maemo missing in Target Options



  • Hi

    I am new to QT. Just downloaded and installed "qt-sdk-win-opensource-2010.05". I am working on windows vista. In Project Setup dialog, under target for project I could find only Desktop and nothing else. I have verified in Tools -> Options -> Qt4 under Qt versions tab

    Auto-Detected
    Qt in Path <Not Found>

    Manual
    4.7.0 c:\qt\2010.05\qt\bin\qmake.exe

    Also under S60 SDKs tab it completely shows blank.

    What I am supposed to do for adding Symbian and maemo in the target options?

    Please let me know and thanks in advance



  • Why don't you install "Qt SDK RC 1.1":http://labs.qt.nokia.com/2011/04/06/qt-sdk-1-1-rc-released/ . It's much newer and many problems and bugs are gone.


  • Moderators

    Did you install the maemo and symbian parts of the SDK? Check by running the SDK maintainance tool.



  • Thanks for your reply

    Why don’t you install Qt SDK RC 1.1 [labs.qt.nokia.com] . It’s much newer and many problems and bugs are gone.

    I have installed the Qt SDK RC1.1 and now I got symbian and maemo in my target. But below symbian device the installed versions (Qt 4.7.3 for Symbian^1 and Symbian^3) show some warning message :

    "The symbian tool chain does not handle the special characters in the project path well"

    I have tried to run SDK maintainence tool and it gives error message:

    "Could not fetch Updates.xml: Host nds2.fds-forum.nokia.com not found. Only uninstallation is possible."

    Please let me know what went wrong here



  • Further to my previous post, I could n't run any of the example programs provided. Whenever I try to run the example codes I get an error message that "simulator.exe" has stopped working and I am forced to quit the application. Then comes another error message dialog that:

    On the tab the heading is "Microsoft Visual C++ Runtime Library" and the error message is:

    "This application has requested the Runtime to terminate it in an unusual way. Please contact the application support team for more information"

    What could be the problem?



  • Please let me know whether Qt SDK RC 1.1 [labs.qt.nokia.com] works fine on Vista (32 bit system) or not. I could n't run the example programs provided as well. When I try to run, simulator crashes with following message on application output for animatedtiles example

    Starting C:\QtSDK\Examples\4.7\animation\animatedtiles-build-simulator\debug\animatedtiles.exe...
    Waiting for reply from simulator timed out
    Invalid parameter passed to C runtime function.
    Invalid parameter passed to C runtime function.
    C:\QtSDK\Examples\4.7\animation\animatedtiles-build-simulator\debug\animatedtiles.exe exited with code 3

    The same sdk works fine on my colleagues Windows Xp SP3 and he can run all the examples well.

    Has anyone faced such problems in vista?? Please let me know



  • [quote author="u2bpavankumar" date="1303383293"]Please let me know whether Qt SDK RC 1.1 [labs.qt.nokia.com] works fine on Vista (32 bit system) or not. I could n't run the example programs provided as well. When I try to run, simulator crashes with following message on application output for animatedtiles example

    Starting C:\QtSDK\Examples\4.7\animation\animatedtiles-build-simulator\debug\animatedtiles.exe...
    Waiting for reply from simulator timed out
    Invalid parameter passed to C runtime function.
    Invalid parameter passed to C runtime function.
    C:\QtSDK\Examples\4.7\animation\animatedtiles-build-simulator\debug\animatedtiles.exe exited with code 3

    The same sdk works fine on my colleagues Windows Xp SP3 and he can run all the examples well.

    Has anyone faced such problems in vista?? Please let me know[/quote]

    I have this problem, did you figured out how to solve? thanks in advance


Log in to reply