Installing Qt on Linux CentOS 5.4 or 5.5

  • Hi,

    I am not able to install Qt SDK 1.1 beta on my Linux CentOS 5.5.It says it does not have the required GLIB..below is the message i was informed

    [root@localhost mnt]# ./
    ./ /usr/lib64/ version `GLIBCXX_3.4.9' not found (required by ./

    where can I get that GLIBCXX_3.4.9 and how to install it ?? can somebody shed light on this ??

  • "Something similar.":

    Which version is your gcc?

  • gcc is 4.1.2..

  • Same here on RHEL5.2. It's a documented bug, and the link is... this one ( ). Reason for that behavior is found here (i think) ( ).

    As i'm working day & night with Qt, what I did was:

    • download "qt-everywhere-opensource-src-4.7.2.tar.gz"
    • follow instructions on compiling and installing (README or INSTALL file)
    • download ""
    • follow instructions on compiling and installing (README file)
    • continue working with the new version of qt creator

    Lenghty process, though... About 3h on a Q9400+QuadroFX5500+etc.

    EDIT: correcting links

  • thanks a million..lemme try this

  • kindly also lemme know if any extra settings are required..

  • Mmm... I think CentOS (or RHEL) ISO or DVD is to be kept close at all times. I have the RHEL one in ISO format right in the Desktop...


    • I don't recall installing anything but the two Qt packages mentioned. I don't know if any of the packages I have installed is also required.
    • There were no extra settings needed, just "./configure", "./make" and "./make install" for Qt 4.7.2 and "./qmake ../" and "make" for Qt Creator), although this depends on your specific system, project, other libraries used...

    Will keep reading! :)

    PS: the files are INSTALL for Qt 4.7.2 and README for Qt Creator 2.1.0
    PPS: i don't recommend trying Qt Creator 2.2.0 as I couldn't compile it successfully...


  • Thanks a lot...I will install it and get back to you for giving many more thanks :-)

Log in to reply

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.