Important: Please read the Qt Code of Conduct -

Qt configure & build problem using ubuntu 10.10

  • Hi,

    I've been using qt (source) for a while now.

    I just did a clean install on my computer. Using ubuntu 10.10 from here:
    I've got qt source package from here:
    (all required dependencies are in place)

    Now I've got multiple issues while trying to configure & build, which I didn't have before:

    the configure command I use:
    $ ./configure -v -confirm-license -opensource -dbus -phonon -phonon-backend -opengl -xrender -xrandr -xfixes -xinerama -xsync -xshape -no-declarative -nomake demos -nomake examples

    the error message I've got:
    bash: ./configure: /bin/sh^M: bad interpreter: No such file or directory

    I found a solution for this, it was a known issue some time ago
    the .configure file format had to be adjusted using dos2unix
    (I tried older qt source's, eg: 4.7.0, I used before without issues, they don't work either anymore)

    Once it's done there is an another issue while trying to execute the same command, the error message is:
    You don't seem to have 'make' or 'gmake' in your PATH.
    Cannot proceed.

    no make?!? = )

    I found also others had a similar issue, but there is no working solution, nor the root cause is know for this.

    Anybody have any ideas?

    Thank you!

  • end of line is in windows mode (\r\n) and the script expects unix end of lines.

    Either get the source from git (which converts end of line to native machine) or convert all your end of lines in your code, with something like
    find . -type f -iname '*.sh' | xargs dos2unix

  • Thank you for the answer!
    As I said I figured already this part out, but the problem(s) still remain.

    On top of a clean install of ubuntu 10.10, using qt downloaded from the link mentioned above, configure & build doesn't work.

    Anyone else having a same problem? or is it just me?

    The worst part is, I tried older version of ubuntu, 9.10, and older qt, 4.7.0, which was working ok, but I have the same problem now using those as well.

    So there is something wrong with the tools using.

    I'm using the very same qt package on my macbook, it works ok there.

  • I've add the same problem, just a bit more vicious as it was link to patch tools, which does not support mixed end of line. I fixed it the way I told you. However, if I remember correctly, .tgz use unix end of line while zip use windows end of line : maybe you should try downloading "this one":

  • Thank you for your reply!

    Yes, the tar.gz is working indeed in linux, that was never the issue.
    It's about the files in the zip file, the links and the (lack) of instructions on the download page.

    I've been using the zip version so far without any problem, but not anymore.
    The page/instructions (or the files) could be updated preventing others having the same problem.

  • hello Maxavadallat,

    I have same problem for linux and i also tried with tar.gz files. It is still not working? plz provide solution as u told tar.gz is working.

    Thank You.

  • are you trying to build Qt from the sources?
    what version of Qt are you trying to build?
    what steps have you done and what errors have you got?

  • Hello andreyc,

    Thank You so much for your quick reply..
    I just tried it with another version and it is working for me..sorry for the trouble..

    Thank You.

  • [quote author="mahi prajapati" date="1406867785"]Hello andreyc,

    Thank You so much for your quick reply..
    I just tried it with another version and it is working for me..sorry for the trouble..

    Thank You.[/quote]

    Please edit it as "Solved" in the heading.

    Thank you

Log in to reply