SOLVED: Assertion error launching QtCreator or code examples with OpenGL in VirtualBox



  • ****This problem was caused by mixed up PATHs. Would delete this post if I could, thanks.

    I am running QtCreator, which comes with Qt 5.3.2 on Windows 7 Ultimate (64bit) in a VirtualBox (4.3.18) VM on a late model MacBook Pro, OS X Yosemite 10.10.1. I have installed the VirtualBox Guest CD tools and have 3d acceleration enabled. So the graphics driver in my DeviceManager reports that it is the VirtualBox Graphics Adapter.
    On startup, QtCreator will complain that I do not have zlib1.dll on it's PATH. It will complain three times, and then QtCreator comes up just fine anyhow.

    When I to add zlib1.dll to the system PATH for this, then QtCreator starts up without incident. Its a pretty lean VM and I don't know if zlib1.dll comes with windows or with Qt? Not sure why I did not have it.

    Either way, the first time that I run example apps that reference OpenGL, I get an Assertion Error dialog box which points to libGLESv2d.dll having trouble. The file path is too long to determine the whole source file name, but it is on line 387 of ..\3rdparty\angle\src\libGLES..\rendere...ils.cpp

    Again, if I click Ignore three times in the reappearing Assertion Msg Box, the program then runs fine.



  • LongPathTool will be useful for your problem, try it out.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.