Qt Serial Port Echoes Input Qt Serial Port Echoes Input



  • I'm using Kubuntu 14. I have a gateway device plugged into /dev/ttyUSB0. When I use screen and send a command, I only get the response from the gateway. However, in my Qt program, (using Qt Serial Port), my command is always echoed back to me. I disabled echo on the device using stty -F /dev/ttyUSB0 -echo.

    There is a similar problem here: " linux-c-serial-port-echoes-output":http://stackoverflow.com/questions/12506836/linux-c-serial-port-echoes-output. However it looks like it was never solved and I tried some of the suggestions there. How would I change the thermios settings using Qt?

    I could try to program around the echo, but I would prefer to not deal with it. Any help would be appreciated.



  • What are you using in Qt for this? Have you tried with the sample terminal app that comes with the Qt Serial sources?



  • As I say in the original post, I'm using Qt Serial Port. As the reference states:

    bq. The following items are not supported by this module:

    • Terminal features, such as echo, control CR/LF, and so on.
    • Text mode.
    • Configuring timeouts and delays while reading or writing.
    • Pinout signal change notification.


  • Yes, to operate the RS232 port. But where do you display the data and what are you using to send data to the QtSerialPort module?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.