Problem running QML example



  • I’m new to Qt and have recently installed Qt v5.3.1 (OpenGL 32bit) on Windows 8- bit.I am using VS 2013 Pro. I have tried an example for calculator (Qt5.3.1\Examples\Qt-5.3\quick\demos). It's solution build successfully. But while debugging output will be an empty widget.No button for keys/operations are shown,and following errors are shown in the output panel.

    QWindowsGLContext::getProcAddress: Unable to resolve 'glGenBuffers'
    QWindowsGLContext::getProcAddress: Unable to resolve 'glGenBuffersOES'
    QWindowsGLContext::getProcAddress: Unable to resolve 'glGenBuffersARB'
    ....
    ....
    ....

    My system is using the graphics card "ATI Radeon HD 4300/4500 Series (Microsoft Corporation - WDDM v1.1)"
    and I've recently installed "Catalyst Software Suite(Display Driver ver. 8.97.100.7,OpenCL(tm) Driver 10.0.937.2,Catalyst Control Center 2012.1116.1514.27190)" in the assumption that it will support openGL 2. But still the problem persists!

    I have also tried installing Qt v5.3.1 (ANGLE). When compiling the sample am getting an error like "Cannot open include file: 'GLES2/gl2.h': No such file or directory".

    What could be the solution to this problem?



  • Welcome to the forum. I strongly suspect that OpenGL drivers are not installed properly. I'm not sure about which one to install for your box. May be your hardware vendor support guys should be able to help you on this.



  • It sounds like your problem is similar to mine (see my post from a couple of weeks ago). It was suggested that I download and use the Qt version that is not for OpenGL. I didn't do this because I use VS 2010 and the version of Qt is for VS 2013. Since you have VS 2013, you could easily check if this solves the problem.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.