[SOLVED] QtCreator 4.8.1 - Qt libraries 4.8.5 for Windows (minGW 4.4) and Mingw 4.4 GDB Debugging HELL



  • All,

    can you please help me to find what is going on.

    First i want to let you know that :

    • I'm working on Windows7 64bit
    • I uninstalled all previous version of any qt related component (QtSDK, QtCreators, Qt Libs, Own build qt versions, etc)
    • I also deleted all data within my appdata folder related to any qtcreator/qt version ever.

    So,

    I downloaded:

    "Mingw 4.4" using forum thread (http://qt-project.org/forums/viewthread/21079), see last comment!

    "Qt libraries 4.8.5 for Windows (minGW 4.4, 317 MB) (Info) (http://qt-project.org/downloads)

    "Qt Creator 2.8.1 for Windows" (53 MB) (Info) (http://qt-project.org/downloads)

    I installed:

    mingw4.4 (simple copy to c:\qt\mingw) and added the location to system PATH

    Qt libs 4.8.5. Refering to the mingw i downloaded

    QtCreator 4.8.1

    I configured:

    Manually added Qt version 4.8.5 within the Tools >> Options >> Build & Run >> Qt Version tab. (in my case: c:\qt\4.8.5\win32\mingw\shared\bin\qmake.exe)

    I adapted the Desktop (default) Kit, which was under the manual field, and set the following settings

    Name: Desktop
    Device Type: Desktop
    Device: Local PC ( default for Desktop)
    Sysroot: <empty>
    Compiler: MinGW (x86 32bit in c:\qt\mingw\bin)
    Debugger: GDN Enging Using: "C:\qt\mingw\bin\gdb.exe"
    Qt version: Qt 4.8.5 (shared)
    Qt mkspec: <empty>
    --> <empty> = empty string

    I created a new Simple Helloworld Qt Gui Application (not qml).
    Which builds perfectly on both debug as release.
    But, when trying to start it in debug, i get the message="The gdb process terminated", title="Unexpected GDB Exit"

    The release works perfect,I tried to run my app from console using gdb which seems to be working perfect as well...

    So the question: WHY HO WHY, is QtCreator NOT working at all!

    Can someone please help me, as I spent a whole day trying to install, uninstall, clean install and nothing seems to be working: indicating I 'm still doing something wrong. The information coming from QtCreator\GDB is not very helpfull at all, leaving me in the dark...

    Hoping for the best, I thank you for any feedback or comment!

    RvN

    PS: still trying to fix it myself :)


  • Moderators

    Hi,

    [quote]

    ... added the location to system PATH

    [/quote]Don't do that, because it increases the risk of wrongly-linked DLLs. Remove all references to MinGW, GDB, and Qt from your PATH.



  • Although not the solution, I thank you for the info.

    On the other hand, I found a solution for my problem.

    I was smart enough to copy the mingw and pythongdb directories from the QtSDK i had previously installed. I started using those 2 components, and all seems to be working after a small configuration change.

    It's a pitty that nowhere i could find any information towards this (or I didn't find it) in the QT project docs.

    I had to change the debugger in the Desktop kit (see above):
    Debugger: GDN Enging Using: C:\qt\pythongdb\python_2.7based\gdb-i686-pc-mingw32.exe

    That seems to do the trick.

    I hope this is helpful for others having troubles setting this environment up.

    Regards


  • Moderators

    Thank you for sharing your solution. Happy coding!


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.