Linker fails using qt-project built standalone with a strange error



  • Hello There,

    I just hope someone can help me since this issue gets really miserable.

    What I have done:

    1. Downloaded "Qt 5.1.0 for Linux 64-bit (416 MB)" from http://qt-project.org/downloads
    2. Installed to default path, including sources
    3. Set PATH variable in .bash_profile so qmake is found
    4. Created a tiny application what just opens a window using "webkitwidgets" and downloads a website.
    5. Complied on Windows. Works fine there. Tried to compile on linux.
    6. qmake was fine. Makefile is generated and looks okay.
    7. Miserable errors are happening on make:
      [code]
      g++ -Wl,-rpath,/opt/Qt5.1.0/5.1.0/gcc_64 -Wl,-rpath,/opt/Qt5.1.0/5.1.0/gcc_64/lib -Wl,-rpath-link,/opt/Qt5.1.0/5.1.0/gcc_64/lib -o bin/JsRendererWebkit WebkitJs.o main.o moc_WebkitJs.o -L/opt/Qt5.1.0//5.1.0/gcc_64/lib -lQt5WebKitWidgets -lQt5Quick -lQt5OpenGL -lQt5PrintSupport -lQt5Declarative -lQt5WebKit -lQt5Qml -lQt5Widgets -lQt5Network -lQt5Sensors -lQt5Script -lQt5Gui -lQt5Core -lGL -lpthread
      /opt/Qt5.1.0//5.1.0/gcc_64/lib/libQt5WebKit.so: undefined reference to deflateBound@ZLIB_1.2.0' /opt/Qt5.1.0//5.1.0/gcc_64/lib/libQt5WebKit.so: undefined reference tog_variant_ref'
      /opt/Qt5.1.0//5.1.0/gcc_64/lib/libQt5WebKit.so: undefined reference to std::__detail::_List_node_base::_M_hook(std::__detail::_List_node_base*)@GLIBCXX_3.4.15' /opt/Qt5.1.0//5.1.0/gcc_64/lib/libQt5WebKit.so: undefined reference togst_x_overlay_set_window_handle'
      /usr/lib/gcc/x86_64-redhat-linux/4.4.4/../../../../lib64/libGL.so: undefined reference to xcb_glx_set_client_info_arb' /opt/Qt5.1.0//5.1.0/gcc_64/lib/libQt5WebKit.so: undefined reference togst_query_parse_nth_buffering_range'
      /usr/lib/gcc/x86_64-redhat-linux/4.4.4/../../../../lib64/libGL.so: undefined reference to xcb_glx_create_context_attribs_arb_checked' /usr/lib/gcc/x86_64-redhat-linux/4.4.4/../../../../lib64/libGL.so: undefined reference toxcb_glx_set_client_info_2arb'
      /usr/lib/gcc/x86_64-redhat-linux/4.4.4/../../../../lib64/libGL.so: undefined reference to _XGetRequest' /opt/Qt5.1.0//5.1.0/gcc_64/lib/libQt5WebKit.so: undefined reference tog_variant_unref'
      /opt/Qt5.1.0//5.1.0/gcc_64/lib/libQt5WebKit.so: undefined reference to gst_element_link_pads_full' /opt/Qt5.1.0//5.1.0/gcc_64/lib/libQt5WebKit.so: undefined reference togst_is_initialized'
      /opt/Qt5.1.0//5.1.0/gcc_64/lib/libQt5WebKit.so: undefined reference to `gst_query_get_n_buffering_ranges'
      collect2: ld returned 1 exit status
      make: *** [bin/JsRendererWebkit] Error 1
      [/code]

    The O/S is CentOS 6.0 x64. Both mesa GL, GLU, devels are installed. Libraries are found in /usr/lib64.
    I looked through the net searching for ideas. The only one I found was that gstreamer version might be wrong. So I tried:
    Install gstreamer as:
    [code]
    sudo yum install gstreamer
    Loaded plugins: fastestmirror, refresh-packagekit
    Loading mirror speeds from cached hostfile

    1. I could not find any clue on what gstreamer version the WebKit supplied witn Qt 5.1.0.

    2. Please help me! What should I do to get my make done?

    Thanks :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.