I can't deploy app to Android



  • I'm trying to deploy a simple (sample) app to my Nexus 4 without luck.
    I'm using Ubuntu 13.04 as my developping machine.
    I've done the following:

    • Activate the debbuging mode of the phone
    • I'm using openjdk 7 in Ubuntu
    • I have created a rule: /etc/udev/rules.d/51-android.rule with the line: SUBSYSTEM=="usb", ATTR{idVendor}=="18d1", MODE="0666", GROUP="plugdev"

    Every time I run the application, it asks to create a AVD.

    What could be the problem?



  • I had the same problem under Windows and my Samsung ACE 2.
    I have solved the problem by installing the same Android API version as on my cell phone at my host system.
    In my case API level 10, because ACE 2 has Android 2.3.6 ("Android API levels":http://en.wikipedia.org/wiki/Android_version_history)
    Then if you have activated USB-Debugging and the right driver installed the AVD uses your handy if you run from QtCreator.
    You must select the API version under Projects/Run/Android target SDK.

    Hope that helps


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.