[Solved] QtCreator and Android SDK versions handling



  • Can someone explain what the reason is, that I can select under Projects/Run Settings/Package configurations/Android target SDK the "android-17" only. Come this from the Android SDK, from the Qt or something else?

    The real problem is, that this stops me to use my android device (Version 2.3.6; SDKVersion 10) as device. The QtCreator looks for a device supporting SDKVersion 17. (In principe it works on my computer, when I use eclipse with the same SDK and NDK)

    Where can I change this information? I have added the uses-sdk information in the manifest but without success.

    Thanks for any help


  • Moderators

    AFAIK this is the API level of the "Android version":http://en.wikipedia.org/wiki/Android_version_history you are targeting.



  • Yes, but from where get QtCreator this information. The Manifest file entry is:
    @<uses-sdk android:minSdkVersion="10"
    android:targetSdkVersion="10"
    android:maxSdkVersion="10" />@

    I have removed the AVD device with API-Level-17 and QtCreator open the AVD Manager and will that I create a new AVD device with this level when I start the program.

    And this is the problem, the IDE need a target device with this level and I haven't it. And I can't change the level (Manifest is ignored)


  • Moderators

    Sorry, I misinterpret your post then.

    I had started with necessitas a while ago, but had problems to get it going. Hope the integration into Qt will help.

    What is your Desktop OS?



  • Solved.

    QtCreator uses the installed Versions from the Android SDK-Manager, so I must install the Android 2.3.3 (API10) package. Then I can select the API-10.

    Now I get other errors but this is a new thread if I can't solve it :-)


  • Moderators

    Good to know that you succeeded in solving your problem.

    Please mark this thread as solved in the title then.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.