Qt 4.8.2 QWebView getting Content-type missing in HTTP POST, defaulting to application/octet-stream



  • i have popup window that is opened from web page ( its paypal popup)
    i capture it and then i try to fix this error as the document suggesting here "Your text to link here...":http://qt-project.org/doc/note_revisions/84/125/view
    but still im getting this error
    here is my QWebView class

    @ class WebView : public QWebView
    {
    Q_OBJECT
    public:
    WebView()
    {
    connect( this->page()->networkAccessManager(),
    SIGNAL(sslErrors(QNetworkReply*, const QList<QSslError> & )),
    this,
    SLOT(sslErrorHandler(QNetworkReply*, const QList<QSslError> & )));
    }

    private slots:
        void sslErrorHandler( QNetworkReply *reply, const QList<QSslError> &errors)
        {
            qDebug() << "sslErrorHandler:";
            foreach (QSslError err, errors)
              qDebug() << "ssl error: " << err;
    
            reply->ignoreSslErrors();
        }
    
    protected:
        QWebView *createWindow(QWebPage::WebWindowType type)
        {
            QWebView *webview = new QWebView;
             
      QUrl tmpUrl = webview->url(); 
      QNetworkRequest request(tmpUrl);
      //request.setHeader(QNetworkRequest::ContentTypeHeader,QVariant("application/x-www-form-urlencoded"));
      request.setHeader(QNetworkRequest::ContentTypeHeader,"application/octet-stream");
      
            //webview->show();
      webview->load(request,QNetworkAccessManager::PostOperation);
            return webview;
        }
    };
    

    @

    what im doing wrong here ?



  • You don't need to load anything in createWindow, just create the QWebView, show it, and return it.



  • yes but i try to avoid this error somehow


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.