QFtp example, problem with download



  • I downloaded Qt 4.6.3 and tried to run QFtp example. After few minutes I've found strange problem: I can start downloading a file and if I click cancel on the progress dialog it disappears, but after that, whole file list seems to be "busy" or locked and I can't even change working directory. Disconnecting and connecting again doesn't work either.

    The problem occurs only when I download files bigger than 10MB. I tried both VS2008 and MinGW4.4 versions of Qt4.6.3.



  • Try to compile your own Qt, and enable the following two defines on top of qftp.cpp (they're commented out in the default build):

    @
    #define QFTPPI_DEBUG
    #define QFTPDTP_DEBUG
    @

    If there's nothing obvious that you can see or fix yourself, I suggest to create a bugreport at bugreports.qt.nokia.com, providing the trace you get from the QFTP* debug macros, and as much other information as possible (which ftp server? active or passive mode? binary or ascii?). Also try different FTP servers, maybe that particular ftpd has a bug?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.