Problems with compiling in Ubuntu.



  • Hello, ledies & gentlemen. My software kit is: Ubuntu 13.04., QT5.1.0.beta. Problems with gcc correct startig up (in Ubuntu the newest version gcc 4.7 is installed). In menu Tools/Options/Bild and Run/Compilers in Auto detected sub-menu there is no any compiler and there is not possibility to define it, only at next submenu /Manual is defined Gcc & Compiler path: /usr/bin/gcc . And as a result after trying to compile usual console c++ application “Hello World” we see the message: g++: Command not found. (absolutely the same result in QT5.0.2 version. (In Windows XP in auto detected sub menu is defined MinGw and no problems with compiling and building not only console applications and Qt app-s too). Thanks for your attention and sorry if something out of range of forum rules from my side, I am the newest here.
    Best regards, Rais Husainov, Minsk.


  • Moderators

    You need to install g++. Qt does not magically setup your whole environment.

    There are many ways to install Qt dependencies in Debian/ Ubuntu. For a start, try this:
    @
    sudo apt-get install build-essential
    @



  • Thank you very much for your very important helping me. Now the problem is solved.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.