Deploying to Raspberry pi - can't seem to launch.



  • So I installed Qt on a Raspberry Pi just fine.
    Created a GUI app with a few basic buttons including a QLabel for displaying an image (Pxmap I believe).
    Running from within the ID it runs just fine. I build the projects with no errors.

    But here's the thing - launching it isn't exactly smooth.
    First off - I thought I could run the executable it from the terminal and it would automatically go graphical... no such luck.
    I thought - ok - so maybe I'll have the desktop load automatically and configure this app to autorun.
    I wrestled around with the desktop config file to wits end with no luck.

    Then I thought I'd just double click the executable while in the desktop. I'm created with a prompt asking me if I want to "Execute" or "Execute in Terminal". Interesting. If I click on Terminal for fun nothing happens... if I click on the Execute button it loads up. I think this prompt perhaps is stopping it from auto running. Either that or I am having zero luck with the autorun configuration.

    Ideally - I'd like to autorun it from the terminal so I can put it in a simple batch.

    Is it just me - did I miss something? When building/coding a Qt program right on the Raspberry Pi, is there no way to simply run it?

    There's a second problem as well.
    When run from the IDE, the image for the QLabel comes up just fine (it loads a jpg from the application directly). When I run the profram outside of the IDE by double clicking the executable - it doesn't find the JPGs... even though everything is right there in the same directory.

    Do I need the commercial version to do what I want to do (which would be fine with me if I could get the thing installed - it fails).

    I tried setting up a cross compiler on a full Linux box but to date I have had zero luck getting it to work (well - I am getting REALLY close but no cigar yet).



  • Really?
    No one has any feedback?

    Looking on line I see some people running QMLViewer or something like that - but when starting a QML project but then there's no Qt Designer for use.

    Really hoping someone can point me in the right direction here...



  • First, on launching your program, you might want to try opening a terminal window while in your graphical desktop environment and launching the app from there. That should give you some idea if there are any errors. My guess from your first question and your second is that you don't have your paths sorted out. It is also possible that you don't have the Qt libraries in some directory where your applications can access them (if it runs OK in the IDE, but fails otherwise, this is often the case).

    As for getting it to launch automatically, you haven't told us what distribution you are using and what desktop you are using. Answers to both of these questions will help people guide you on launching your application automatically.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.