Qt5 static doesn't compile.



  • Hi ppl!

    Happy End-of-the-World-2012 events!

    I'm trying to build some minimalistic static Qt 5.0.0. I'm forcing all what looks not need to be disabled by build options.

    @
    call ..\qt-5.0.0\configure.bat -platform win32-msvc2010 ^
    -xplatform win32-msvc2010_s_mini -debug-and-release -static ^
    -no-accessibility -no-sql-sqlite -no-sql-sqlite2 ^
    -no-sql-mysql -no-sql-psql -no-opengl -no-openvg ^
    -no-audio-backend ^
    -no-sse2 -no-sse3 -no-ssse3 ^
    -no-sse4.1 -no-sse4.2 -no-avx -no-avx2 -no-gif ^
    -qt-libpng -no-libjpeg -no-openssl -no-dbus ^
    -no-style-fusion ^
    -confirm-license -opensource
    @

    But what I get is this:

    @
    QMAKESPEC...................win32-msvc2010_s_mini (commandline)
    Architecture................i386, features:
    Host Architecture...........i386, features:
    Maketool....................nmake
    Debug build.................yes (combined)
    Default build...............debug
    Force debug info............no
    C++11 support...............auto
    Link Time Code Generation...no
    Accessibility support.......no
    RTTI support................yes
    SSE2 support................no
    SSE3 support................no
    SSSE3 support...............no
    SSE4.1 support..............no
    SSE4.2 support..............no
    AVX support.................no
    AVX2 support................no
    NEON support................no
    IWMMXT support..............no
    OpenGL support..............no
    Large File support..........yes
    NIS support.................no
    Iconv support...............no
    Inotify support.............no
    Glib support................no
    CUPS support................no
    OpenVG support..............no
    OpenSSL support.............no
    QtDBus support..............no
    QtWidgets module support....yes
    QML debugging...............yes
    DirectWrite support.........no
    Use system proxies..........no

    Third Party Libraries:
    ZLIB support............qt
    GIF support.............no
    JPEG support............no
    PNG support.............yes
    FreeType support........yes

    PCRE support............qt
    ICU support.............no
    ANGLE...................no
    

    Styles:
    Windows.................yes
    Windows XP..............yes
    Windows Vista...........yes
    Fusion..................no
    Windows CE..............no
    Windows Mobile..........no

    Sql Drivers:
    ODBC....................no
    MySQL...................no
    OCI.....................no
    PostgreSQL..............no
    TDS.....................no
    DB2.....................no
    SQLite..................no (qt)
    SQLite2.................no
    InterBase...............no

    Sources are in..............C:\Qt\qt-5.0.0\qtbase
    Build is done in............C:\Qt\qt-5.0.0-msvc2010_x86_s_mini\qtbase
    Install prefix..............C:\Qt\qt-5.0.0-msvc2010_x86_s_mini\qtbase
    Headers installed to........C:\Qt\qt-5.0.0-msvc2010_x86_s_mini\qtbase\include
    Libraries installed to......C:\Qt\qt-5.0.0-msvc2010_x86_s_mini\qtbase\lib
    Arch-dep. data to...........C:\Qt\qt-5.0.0-msvc2010_x86_s_mini\qtbase
    Plugins installed to........C:\Qt\qt-5.0.0-msvc2010_x86_s_mini\qtbase\plugins
    Library execs installed to..
    QML1 imports installed to...C:\Qt\qt-5.0.0-msvc2010_x86_s_mini\qtbase\imports
    QML2 imports installed to...C:\Qt\qt-5.0.0-msvc2010_x86_s_mini\qtbase\qml
    Binaries installed to.......C:\Qt\qt-5.0.0-msvc2010_x86_s_mini\qtbase\bin
    Arch-indep. data to.........C:\Qt\qt-5.0.0-msvc2010_x86_s_mini\qtbase
    Docs installed to...........C:\Qt\qt-5.0.0-msvc2010_x86_s_mini\qtbase\doc
    Translations installed to...C:\Qt\qt-5.0.0-msvc2010_x86_s_mini\qtbase\translatio
    ns
    Examples installed to.......C:\Qt\qt-5.0.0-msvc2010_x86_s_mini\qtbase\examples
    Tests installed to..........C:\Qt\qt-5.0.0-msvc2010_x86_s_mini\qtbase\tests
    WARNING: Using static linking will disable the use of plugins.
    Make sure you compile ALL needed modules into the library.

    Generating Visual Studio project files...
    Project WARNING: You should probably load(qt_build_config) first in bootstrap.pr
    o for QtBootstrap, as the latter also load()s qt_module.
    Project MESSAGE: Not doing so may lead to qt_module.prf overriding compiler/link
    er options in your .pro file.
    Project MESSAGE: Ignore this warning with CONFIG+=no_qt_module_warning if you kn
    ow what you are doing.
    Project ERROR: Project has no top-level .qmake.conf file.
    Qmake failed, return code 3

    Generating Makefiles...
    *** qtbase/configure exited with non-zero status.
    @

    What this error message can mean and how I can fix it?

    Actually, the win32-msvc2010_s_mini is a copy of original win32-msvc2010 with some minor twicks.

    WBR,
    AG



  • I think your packet lacks a file named ".qmake.conf". Download the whole packet again and try to run configure properly.



  • I did complete download of .zip package. The same package actually compiles shared for x86/x64 msvc2010 and for mingw32 but this setup/config does not compile.

    I know I'm cheating a little because I disable nearly everything to make size smaller but as far I do not patch any files in the package the configure.exe should not fail. at least I must say what something depends from disable component, proceed the process and actually finish the preparation. At lease it is how I imagine things. So I assume it is a BUG.

    What I also noticed that qtbase folder contains the desired Makefile but the root folder of the Qt package does not. So, I was able to build qtbase I need, but rest is seams to be in bad shape - the configure.exe did not made the rest...

    WBR,
    AG



  • I am getting this error after this commit. Did you find any solution for this?
    "Fix for QTBUG-29400":https://codereview.qt-project.org/#patch,sidebyside,46350,1,tools/configure/configureapp.cpp



  • it's having trouble creating the VS project files.
    the easy solution is to not create them using -no-vcproj



  • Thanks! I'll try -no-vcproj too.



  • Had the same issue. (setup: Win7_x86 & VS2010express & qt5 from git)
    Solved it by setting environment variable @set QMAKESPEC=%QtDir%\qtbase\mkspecs\win32-msvc2010@

    with QtDir pointing to git folder and running following configure command (notice "-fully-process" flag)

    @configure -developer-build -opensource -nomake examples -nomake tests -opengl desktop -mp -fully-process -confirm-license@

    BR



  • Thanks, I'll try this way too. The QMAKESPEC variable was NOT set in my case.



  • I have the same problem for configure shared lib.

    I found the solution
    copy .qmake.conf to

    qtbase\src\corelib
    qtbase\src\gui
    ....
    every directionary


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.