Cannot load flash plugin on Mac



  • Hi all,

    Could you please share me your expirence of show flash on Mac? Do I need 32-bit Qt and compile my QtWebit program into 32-bit? I use 64-bit Qt 4.8.3. My program can load other NPAPI plugins but cannot load flash plugin.

    Thanks,
    Bobber



  • Hi Bobber,

    I lately bumped into the same issue. After a lot of research I found that "this patch":https://bugs.webkit.org/attachment.cgi?id=164361&action=review is compatibile with QtWebKit sources from Qt 4.8.3 source code (if I’m not wrong it’s QtWebKit 2.2.3). It will solve this issue (you'll be able to use 64bit flash plugin).

    This is one of a few patch versions for this bug: https://bugs.webkit.org/show_bug.cgi?id=72358 (don’t be influenced by it’s title). Newer patches are applicable to the standalone QtWebKit 2.3 source which can be downloaded from gitorious: https://gitorious.org/+qtwebkit-developers/webkit/qtwebkit-23/. I tried the newest and it worked for the flash issue but with this version of QtWebKit I bumped into another issue probably related with JavaScript interpreter (very slow JS code evaluation with 100% CPU usage …). It seems that this is still more dev than stable branch, but if you have time you can try it (and give here a feedback ;) ). In meantime there may occur some amendments which solved the JS issue.



  • Hi Michal,

    It's great to hear that you can load 64-bit flash plugin. I successfully apply Andy's path agaist QtWebKit 2.3 source. I'm compiling it by following command:
    QTDIR=/usr/local/Trolltech/Qt-4.8.4 Tools/Scripts/build-webkit --qt --no-video

    Could you please tell me if I do it in correct way?

    I will update you once I can run test after compiling.

    BTW, I can successfully load 32-bit flash player with 32-bit qtwebkit.

    Thanks,
    Bobber



  • Hi Bobber,

    I think it's ok, but in my case I had problems to build it with xcodebuild (which is used by default). Maybe that's because I'm more unix than Mac OS user ;) so I prefer to use standard make command instead of Xcode tools.

    To use unix makefiles and make command I had to use "-spec". Moreover I also passed “-j” argument to the make command to perform build in parallel in case of multicore processor (to speed-up build process). So the command would look like:

    @QTDIR=/usr/local/Trolltech/Qt-4.8.4 Tools/Scripts/build-webkit --qt --no-video -spec macx-g++ --makeargs="-jN"@

    where N is number of cores (or threads in case of Intel’s hyper-threading).

    EDIT: I've just noticed that in the previous post I failed to add url to the patch for Qt 4.8.3 source code, sorry. :) It should to look like this:

    bq. After a lot of research I found that "this patch":https://bugs.webkit.org/attachment.cgi?id=164361&action=review is compatibile with QtWebKit sources from Qt 4.8.3 source code [...]



  • Hi Michal,

    Much thanks for your help. Finally I successfully applyed Andy's patch https://bugs.webkit.org/attachment.cgi?id=164361&action=review and modified some files in order as bug https://bugs.webkit.org/show_bug.cgi?id=102057. Now I can load 64-bit flash player with qtwebkit2.3.

    The problem that I found is that I cannot click "Allow" if flash player if I need to use camera in flash player. This issue also exists in 32-bit qtwebkit without Andy's patch.

    For all that's interested flash player and qtwebkit32, please do following thing in order to load flash player:

    1. download qtwebkit23 from gitorious: https://gitorious.org/+qtwebkit-developers/webkit/qtwebkit-23/.
    2. download Andy's patch in https://bugs.webkit.org/show_bug.cgi?id=72358, and applay in qtwebit23 as 'patch -p0 < andy's patch'
    3. modify code as https://bugs.webkit.org/show_bug.cgi?id=102057.
    4. compile qtwebkit23 as QTDIR=/usr/local/Trolltech/Qt-4.8.4 Tools/Scripts/build-webkit --qt --no-video -spec macx-g++ --makeargs="-jN"
    5. enjoy it:-).

    BTW, qtwebkit23 is not offical version yet. You need to consider it before using it.

    Thanks,
    Bobber



  • Hi Bobber,

    Thanks for the feedback!

    So you didn't noticed any troubles related with JavaScript code evaluation? To be precise I mean http://doc-snapshot.qt-project.org/4.8/qwebframe.html#evaluateJavaScript.

    I remember that I had problems while trying to use QtWebKit 2.3 build with Fancy Browser from Qt examples and e.g. trying to load youtube.com. Page was loading up to about 90% (progress) then it was starting to use 100% of CPU and was eating a lot of RAM.

    If this is not the case then it's great news.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.