[SOLVED] Make error: **** missing operator for first qt program



  • Hi, I'm trying to compile my first program. Either from the book (C++ programming with Qt4) or from this tutorial:
    http://doc.qt.digia.com/4.3/qmake-tutorial.html

    But I'm always getting the same error when I'm trying to run make.

    Cmd.exe:

    [quote]
    C:\qtbookexamples\chap01\hello>make
    make -f Makefile.Debug
    make [1]: Entering directory C:/qtbookexamples/chap01/hello' Makefile.Debug:59: *** missing separator. Stop. make [1]: Leaving directoryC:/qtbookexamples/chap01/hello'
    make: *** [debug] Error 2
    [/quote]

    This is the the Makefile.Debug:59 line:
    <<

    Around it:

    [quote]

    .SUFFIXES: .c .cpp .cc .cxx

    {.}.cpp{debug}.obj::
    57.$(CXX) -c $(CXXFLAGS) $(INCPATH) -Fodebug\ @<<
    58.$<
    59.<<

    61.{.}.cc{debug}.obj::
    62.$(CXX) -c $(CXXFLAGS) $(INCPATH) -Fodebug\ @<<

    1. $<
      64.<<
      [/quote]

    The other program also had an error at line 60: <<

    Can anybody help me resolve the problem, so I can compile my first qt program?



  • I solved my own problematic by using the command prompt (MinGW) from the start menu/all program/QT/desktop folder.


  • Moderators

    Glad you found the problem! Be sure and edit your initial post to add [Solved] to the title. Thanks!


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.