[SOLVED] Qt version is invalid.



  • I am working on Linux and I have installed Qt Creator 2.5.2, Qt libraries 4.7.4 and 4.4.3 all from sources. I cannot install the binaries directly for incompatibility between versions. The installation processes for both Qt 4.7.4 and Qt 4.4.3 were the same. The issue I am facing is that Qt Creator recognizes Qt 4.7.4 but not Qt 4.4.3, with the error

    bq. The Qt version is invalid : Could not determine the path to the binaries of the Qt installation, maybe the path is wrong.

    Well each library is installed in /home/$username/qt/Qt-$version. When I manually compile a project with

    @cd directory
    /home/$username/qt/Qt-4.4.3/qmake $PATHPRO
    make
    @

    Everything work as a charm and I can run the app.

    What did I tried?

    • Recompile Qt-4.4.3
    • Check the folder permissions
    • Restart Qt Creator
    • Smash my head on my desktop

    Any thoughts?


  • Moderators

    Creator started to look at libQtCore.so.*. It runs "qmake -query" looks for them in QT_INSTALL_LIBS and QT_INSTALL_BINS. Are those two set? Is libQtCore in one of those directories?



  • Many Thanks Tobias problem solved now. Indeed, there were no properties set by qmake and "qmake -query" was empty in the Qt-4.4.3 qmake. So I used qmake -set as described in the "qmake environment reference":http://doc.qt.digia.com/4.7-snapshot/qmake-environment-reference.html


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.