How to install QT on Open Suse?



  • Hello,

    I just tried to install Qt on Open Suse with the 2 commands (using the online installer):

    chmod +x QtSdk-online-linux-x86_64-v1.2.1.run
    ./QtSdk-online-linux-x86_64-v1.2.1.run

    and I got the following error message:

    ./QtSdk-online-linux-x86_64-v1.2.1.run: /lib64/libc.so.6: version `GLIBC_2.11' not found (required by ./QtSdk-online-linux-x86_64-v1.2.1.run)

    I didn't find any information on any libraries needed for installation. If anyone knows how to solve this problem, that would be very helpful.

    Thanks,

    Andreas



  • I forgot to say, I have Open Suse 11.2. It should basically work with this version, shouldn't it?



  • You need to install gcc compiler. You can do this in two ways:
    a) from Yast software management search for gcc
    b) in konsole terminal (command line) type: sudo zypper install gcc


  • Moderators

    That message indicates that your glibc is too old.

    To use the binary installer you will need to upgrade your distribution (upgrading the glibc separately is usually not possible as almost everything else depends on that library). You can of course use the openSuSE Qt packages for desktop development and Qt Creator. I am not sure there are packages for the other architectures supported by the Qt SDK readily available though.



  • Sorry, I'm absolutely new to linux.
    I already have a gcc compiler, still tried to (re-)install it.

    I'll just post what I got in the terminal:


    merrem@henry:~> sudo zypper install gcc
    File '/repodata/repomd.xml' not found on medium 'http://download.nvidia.com/opensuse/11.2/'

    Abort, retry, ignore? [a/r/i/?] (a): a
    Problem retrieving files from 'NVIDIA Repository'.
    File '/repodata/repomd.xml' not found on medium 'http://download.nvidia.com/opensuse/11.2/'

    Please see the above error message for a hint.
    Warning: Disabling repository 'NVIDIA Repository' because of the above error.
    Loading repository data...
    Warning: Repository 'openSUSE-11.2-Update' appears to outdated. Consider using a different mirror or server.
    Warning: Repository 'openSUSE-11.2-Update' appears to outdated. Consider using a different mirror or server.
    Warning: Repository 'update' appears to outdated. Consider using a different mirror or server.
    Reading installed packages...
    'gcc' is already installed.
    No update candidate for 'gcc'.
    Resolving package dependencies...

    Nothing to do.

    Do you know if the current version is compatible with Open Suse 11.2 at all or if there is an older version which is? Do you know any packages which I might have to install?

    Best,
    Andreas


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.