[Solved] Installing Qt on UBUNTU 11.04 Virtual Machine - The tslib functionality test failed



  • Hello,

    I am trying to install Qt(version 4.4.3) on my Ubuntu 11.04 box. This is targetted for SBC 6000X board. I am using gcc-3.4.5-glibc-2.3.6 toolchain. I have set my path to toolchain, so path is:
    @/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/crosstool/gcc-3.4.5-glibc-2.3.6/arm-linux/bin@

    My tslib installation was successful. I did it using following command.

    @sudo ./configure --host=arm-linux --prefix=/home/rajendra/apps/tslib-arm/tslib/build/ --enable-static --enable-shared@

    Reference: http://billforums.station51.net/viewtopic.php?f=8&t=15

    tslib built successfully, the generated files are at the location : home/rajendra/apps/tslib-arm/tslib

    Now I am trying to build qt. I have downloaded Qt(qt-embedded-linux-opensource-src-4.4.3) from qt.nokia.com.

    I have set paths inside qt-embedded-linux-opensource-src-4.4.3/mkspecs/qws/linux-arm-g++/qmake.conf as follows:

    I have added these lines
    @include(../../common/g++.conf)
    include(../../common/linux.conf)
    include(../../common/qws.conf) #this file is not present at this location?

    QMAKE_INCDIR += /home/rajendra/apps/tslib-arm/tslib/build/include
    QMAKE_LIBDIR += /home/rajendra/apps/tslib-arm/tslib/build/lib@

    I am using following configure command
    ./configure -embedded arm -xplatform qws/linux-arm-g++ -prefix /usr/local/Qt -qt-mouse-tslib -little-endian

    The tslib functionality test failed!
    You might need to modify the include and library search paths by editing
    QMAKE_INCDIR and QMAKE_LIBDIR in
    /home/rajendra/apps/qt-embedded-linux-opensource-src-4.4.3/mkspecs/qws/linux-arm-g++.

    Reference: http://devkit8000.wikispaces.com/file/view/Getting+Started+with+Qt.pdf

    while configuring it is using g++ instead of linux-arm-g++. I am not able to figure out what is missing.

    Can anybody help me ?

    Thanks in advance,
    Rajendra



  • I sorted this out, there was problem in getting linux-arm-g++ so my tslib got built incorrectly.

    @sudo ./configure --host=arm-linux --prefix=/home/rajendra/apps/tslib-arm/build/ --enable-static --enable-shared@

    I created a symbolic link to these paths and then built ts lib as per shown in pdf mentioned at reference.

    http://devkit8000.wikispaces.com/file/view/Getting+Started+with+Qt.pdf

    @sudo ln -s /usr/crosstool/gcc-3.4.5-glibc-2.3.6/arm-linux/bin/arm-linux-gcc /usr/bin/arm-linux-gcc
    sudo ln -s /usr/crosstool/gcc-3.4.5-glibc-2.3.6/arm-linux/bin/arm-linux-g++ /usr/bin/arm-linux-g++
    sudo ln -s /usr/crosstool/gcc-3.4.5-glibc-2.3.6/arm-linux/bin/arm-linux-strip /usr/bin/arm-linux-strip
    sudo ln -s /usr/crosstool/gcc-3.4.5-glibc-2.3.6/arm-linux/bin/arm-linux-ar /usr/bin/arm-linux-ar
    @
    Then I built Qt using following command.
    @sudo ./configure -embedded arm -little-endian -no-armfpa -qt-gfx-transformed -qt-gfx-linuxfb -nomake demos -nomake examples -no-svg -no-phonon -no-qt3support -lrt -no-feature-CURSOR -qt-mouse-tslib@

    This worked for me.

    Thanks
    Rajendra


  • Moderators

    Good to know that your problem has been solved. I am marking your post as solved then. Please mark your thread with [Solved] in the header line next time.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.