[SOLVED]QtCore4.dll missing entry point



  • I'm near to pulling my hair out here in confusion. I used Dependency Walker to go through and identify all the DLLs I need for my application. When I try to run the application from Windows Explorer, I get the following error.
    @The procedure entry point _Z5qFreePv could not be located in the dynamic link library QtCore4.dll@

    I did a good search and most people seem to say that it occurs when the system is linking to an older version of the DLL. I searched my C drive and the only two files are the one in my current QT bin folder and the one I copied into the program folder. In addition, Dependency Walker lists the one in my application folder as the one being referenced.

    After moving all dependencies into the folder and running Walker, it gives me two errors, specifically that sysntfy.dll and GPSVC.dll are 64bit and not 32bit dlls, despite being in the System32 folder. Even more confusing, they are the only ones on my C: drive. Where is QT SDK IDE pulling these from when I run it inside the IDE? And, in my frustration, I have to ask, why can't the IDE just copy the needed DLLs to the release directory?

    I'm obviously missing something, but I'm completely at a loss, and google is not turning up anything applicable that I've seen yet.

    Thanks in advance.

    EDIT: If it matters, and I usually find it does, I'm using mingW on Windows 7 64bit, compiling to 32bit. Pretty sure mingW is restricted to 32bit anyway. Also, realized there was a deployment forum that was probably more applicable. Sorry about that.



  • Solved my own problem. I figured it couldn't actually be a problem with QtCore4.dll, so I searched for all the other QT related DLLs needed, and found different versions elsewhere. Trial and error got me a combination that worked.

    Still would like to know why the IDE can't solve that problem for me, but that's just me complaining.



  • Most likely you copied the wrong QtCore4.dll - by wrong i mean built with a different compiler that the one you built your application, have you copied it from: SDK_INSTALL_DIR\Desktop\Qt\4.8.1\mingw\bin? There is another one in SDK_INSTALL_DIR\QtCreator\bin this is used by Creator and it's built with visual studio (at least this was some time ago and i don't think it changed)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.