Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Integrating Qt with visual c++ 2008



  • Hello, help me!
    I have done the integration with QT and visual c++ 2008, I have done the configuration like "http://rajorshi.net/blog/2009/01/using-qt-with-msvc-express-2008/comment-page-2/#comment-35272", now Qt is integrated with Visual c++ 2008, soh, when I run the project “HelloQt” that I created…..

    1>—— Build started: Project: HelloQt, Configuration: Debug Win32 ——
    1>Performing Makefile project actions
    1>’qmake’ não é reconhecido como um comando interno
    1>ou externo, um programa operável ou um arquivo em lotes.
    1>Project : error PRJ0019: A tool returned an error code from “Performing Makefile project actions”
    1>Build log was saved at “file://c:\Users\lulu\Documents\Visual Studio 2008\Projects\HelloQt\HelloQt\Debug\BuildLog.htm”
    1>HelloQt – 1 error(s), 0 warning(s)
    ========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

    Somebody know what is wrong?



  • Hi,
    message says that qmake.exe is not recognized. You can check in cmd - you should get the same message when typing "qmake".

    You should definitely check your PATH - have you got [drive]:[qt-dir]\bin path properly set?



  • Thanks you so much for this answer, but I have check the PATH so many times, look:
    C:\Qt\4.7.4\bin, I don't know what I need to do now.....help me!



  • You'd better show your error



  • Hello,

    I think you have to set "QMAKESPEC = win32-msvc2008" pr similar in your system variables.
    Check your project options to find whether the QMAKESPEC is initialized correctly. By default i think Qt uses MingW compiler.

    If you want to use both MSVC and MingW then you need to have two different installations of Qt, once for each environment. Once you recompile one version with MSVC, you can no longer use it in MingW as the file formats are different.

    Best Regards
    Ansif


Log in to reply