Deploying an Application on Windows



  • Howdy people,

    I've made an application using Qt Creator and it runs flawlessly on my Arch Linux desktop computer. Now I want to give it to my friends, but the problem is that most of them use Windows. Therefore I'm required to compile the application for Windows systems, and while that's not a problem, I can't seem to find the right DLL-files.

    When I had compiled my application I followed this YouTube tutorial to find the right DLL-files:
    http://www.youtube.com/watch?v=X1BsPQue5-k

    I copied all DLL-files that Dependency Walker told me were missing to the same folder as my .exe file is in. Despite that, the application crashes on connect (it's an IRC client and it crashes when you have connected) and I have no idea why.

    I think it's related to what Dependency Walker tells me about IEFRAME.dll, but I'm not sure how to solve it:
    http://delafilen.nu/u/1331814661_DW.png

    QtCore4.dll, QtGui4.dll, QtNetwork4.dll, libgcc_s_dw2-1.dll and mingwm10.dll were all copied from this folder:
    C:\QtSDK\Desktop\Qt\4.7.4\mingw\bin

    What have I done wrong?

    • Martin


  • If your app runs and then crashes afterwards on connect, then it may not be a deployment issue.



  • It runs perfectly fine if I run it from Qt Creator, on both Windows and Linux, though...



  • Then maybe you are including the wrong versions of DLLs with your app?



  • Is there any fool-proof way of finding which version I should include? Can I see the paths to the files Qt Creator uses? I have tried with several different DLLs with the same name, without getting anywhere.



  • I am not that adept in that area myself, hopefully someone more experienced will be able to help you. Does the OS provide you with any information upon the crash that you might want to share?



  • There might be a way of catching that, but I don't know how to do that in Windows. Any help on that would be appreciated too.



  • You can use "dependency walker":http://www.dependencywalker.com/ to get the dependencies of your app. It cannot resolve plugins!



  • [quote author="Scylla" date="1331828262"]You can use "dependency walker":http://www.dependencywalker.com/ to get the dependencies of your app. It cannot resolve plugins![/quote]

    In his first post he already mentioned that he used dependency walker.



  • Sorry, I missed this. We had a similar problem this week. The problem was that there where some different Qt libs in the system folder installed.
    Another problem can be, that if you start you app from Qt Creator, the working path is set explicit. If you start your app anywhere else, the path is different.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.