Nominate our 2022 Qt Champions!

How to use INSERT/REPLACE mode on the IDE?

  • Hi All,

    I'm a beginner on developing software using QTCreator but I'm becoming crazy because I can't do the simple operations which I can do in every developing IDE, how does the INSERT/REPLACE mode work on the QT-Creator IDE?

    If I want to edit a code on the text editor and I want to insert some text or replace some text, I've used the INS button of the keybord to handle the behaviour of the IDE but it doesn't work as expected. I can't exit from the REPLACE mode (shown on the bottom bar).
    Other things that didn't work as expected are the shortcut Ctrl+X, Ctrl+C and Ctrl+V. I'm able to work with cut and paste methods only calling them from the menu, why?

    Where can I find some documentation about how to use the QTCreator IDE?

  • Hi, remember that QT is QuickTime not Qt!
    About the INS operation i try and for me not work...
    -About ctrl-c ctrl-v have you try control if you have CAPS LOCK active?-
    Look info at "QtCreatorDocs":
    What Os are you using?

  • Make sure there are key bindings for the copy, cut and paste actions.

    Qt Creator does not have an overwrite mode (yet), as far as I know for the simple reason that there are platforms that do not use overwrite mode (Macs do not / did not even have an Insert key). However, Qt Creator 2.5 will have support for overwrite mode. If you need it right now update to 2.5 or use the vi mode, which has it too.

  • The insert key works as expected for me. The only indication of the changed mode is the text cursor for me though.

    I don't get any "REPLACE" mode in the bottom bar. Did you end up in vi mode? That one is strange to anybody not used to VI... I tend to just disable the whole plugin in Help->About Plugins just to make sure I never end up in there;-)

  • @gRicky Sounds like you entered the "FakeVim" mode somehow.

    I have the same problem like you... i saw one post from @Chris Kawa, all you have to do is Go to Tools -> Options -> FakeVim and see if the "Use FakeVim" checkbox is selected. If so - deselect it

Log in to reply