Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

[SOLVED] Qt Creator : Auto-detected debugger in tool chains has a wrong path



  • Hi! First time I'm posting, so I hope this question's in the good forum.

    I'm having trouble debugging with Qt Creator. When I hit F5, I get the following error :

    Adapter start failed
    The gdb process failed to start. Either the invoked program 'C:/QtSDK' is missing, or you may have insufficient permissions to invoke the program.

    I googled this error, and found a lot of different solutions, more than often involving old or misconfigured QtCreator.ini. I tried them all to no avail.

    Then, I noticed the following problem in "Tools->Options...->Build And Run->Tool Chains" :

    !http://www.solibic.com/scrshts/qtproblem-20120124.png(Screenshot Tool Chains)!

    The auto-detected debugger is "C:\QtSDK", which is probably why I'm getting this error message. I can't edit this entry, and I don't know how to make it auto-detect the debugger correctly.

    OS : Windows XP SP3 32 bits.
    Version : Qt Creator 2.4.0 based on Qt 4.7.4 (32 bits)

    Thanks a lot in advance for your help!


  • Moderators

    This looks like a SDK installation. If that is indeed the case, then you might want to check "Qt Creator/share/qtcreator/Nokia/toolChains.xml". It has the debuggers used for ABIs. Search for x86-windows-msys-pe-32bit in there and check the path of the debugger used for that.

    Please "file a bug repor":http://bugreports.qt.nokia.com/t against the Qt SDK if there that path is indeed wrong.



  • Here's an excerpt of the file :
    @<data>
    <variable>ToolChain.0</variable>
    <valuemap type="QVariantMap">
    <value key="ProjectExplorer.GccToolChain.Debugger" type="QString">C:/QtSDK</value>
    <value key="ProjectExplorer.GccToolChain.Path" type="QString">C:/QtSDK/mingw/bin/mingw32-g++.exe</value>
    <value key="ProjectExplorer.GccToolChain.TargetAbi" type="QString">x86-windows-msys-pe-32bit</value>
    <value key="ProjectExplorer.ToolChain.DisplayName" type="QString">Mingw as a GCC for Windows targets</value>
    <value key="ProjectExplorer.ToolChain.Id" type="QString">ProjectExplorer.ToolChain.Mingw:C:/QtSDK/mingw/bin/mingw32-g++.exe.x86-windows-msys-pe-32bit</value>
    </valuemap>
    </data>@

    I changed the ProjectExplorer.GccToolChain.Debugger key's value, restarted Qt Creator, and it worked!

    Thanks a lot, Tobias, that was exactly it!

    I filed a "bug report.":https://bugreports.qt.nokia.com/browse/QTCREATORBUG-6865

    Thanks again!


  • Moderators

    Great that the issue is fixed and thanks for the bug report!


Log in to reply