Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

V8 Snapshot Support keeps me from crosscompiling QtWebEngine



  • Solved in this post

    Hi!
    I've been stuck on this little problem for a while and i think i figured out what the problem is but i cant seems to find a proper way to solve it.

    Im currently trying to cross compile Qt 5.15.0 from sources for my Raspberry Pi 4 and everything seems to compile until I reach QtWebEngine.
    My config.summary contains a warning indicating that the V8 snapshot support needs a 32bit environment to work? And if I try to compile it anyway it pulls the same errors as the post I referenced. I tried to pass the "-no-webengine-v8-snapshot" options but it always returns that the option seems unknown, despite me seeing in some other posts

    I dont know if there's a way to disable V8 snapshot support altogether or to make it so that my compiler sees the file in my sysroot? Becaus I checked and the "c++config.h" file is present. My guess is that since i'm compiling against a Rpi sysroot, I dont need to pass the flags "-m32" to the compiler?

    I'm on Ubuntu 20.04 LTS crosscompiling for a Raspberry Pi 4 with Raspbian GNU/Linux 10 (buster). I'm using GCC Linaro arm-linux-gnueabihf 7.4.1.


Log in to reply