Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

QtWebEngine for apple M1



  • Hello,
    I'm working on getting my track fully native (aka universal2) on Mac. I'm with Qt 5.15.2.
    So I compiled Qt twice: once for x86 and once with the -device-option QMAKE_APPLE_DEVICE_ARCHS=arm64 configure option.
    I then used makeuniversal and my binaries and Qt frameworks are universal.. Yay.
    Now I tried qtwebengine. So I know that it needs to be on a relatively recent version of chromium, so I took the 5.15 branch and tried to build. With no luck so far. it fails right away by saying the the extensions are not enabled.
    So I tried to configure it with ../Qt/bin/qmake . -- -webengine-webrtc -webengine-printing-and-pdf -webengine-pepper-plugins
    I also amended the src/buildtools/config/mac_osx.pri
    with this:
    cross_compile {
    GN_TARGET_CPU = $$gnArch($$QT_ARCH)
    gn_args += target_cpu="$$GN_TARGET_CPU"
    }

    so that the args.gn from chromium gets the right arget_cpu.

    But then it fails with requiring some .mm file that is indeed not present on disk.

    Has somebody had success doing this?


Log in to reply