Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

cs student here using qt. had to delete and reinstall and new version keeps throwing a strange hash error.



  • So My old version was 5.15.1 mingw 64bit 8.1.0 and I was having a hard time running code in it and using the debugger. The code I was using was sent to my teacher and it ran fine. He sent me some of his code to run and it did not pass the test cases he wrote for the same code so he concluded it must be qt. I uninstalled it and went to reinstall. Around 30% it gave me this error:
    hash verification failed while downloading. This is a temporary error please retry.
    It does not matter how many times I retry, it does the same thing. Any version I try to install now gives the same message right about the same time. I tried to seek and destroy any qt in my file system and that did not work so I created a new profile for windows and that did not work. when I cancel out of the retry loop it gives me the more specific message :
    cannot fetch archives: cannot verify hash error while downloading http://downlload.qt.io/online/qtsdkrepository/windows_x86/desktop/tools_qtcreator/qt.tools.window_kits_debuggers/2019-11-07-0X64 debuggers and tools-x64_en-us.7z
    or something very close to that. There may be an item or two out of place as I could not copy the error message from qt....That was extremely annoying.

    Please tell me someone has had this issue and can tell me what is going on here. I am on the second to last week of this term and having to code for the rest of this term on my laptop will be an absurd challenge with someone with fingers like mine...



  • I'm seeing the same error on the same file. This is for the online installer for Qt 6.0.2

    Downloading archive "2019-11-07-0X64 Debuggers And Tools-x64_en-us.7z" for component Debugging Tools for Windows

    Error is "Hash verification fails for 2019-11-07-0X64 Debuggers And Tools-x64_en-us.7z"

    Retry redownloads the same file and then results in the same error ad infinitum. Abort cancels the install. Only difference from OP is that this is a fresh install. Never had Qt on this laptop before. Google search results suggest changing the mirror, but I don't see how to do that.


  • Moderators

    Hi, and welcome!

    It sounds like both @deano138 and @ibid49 are being assigned a poorly-performing mirror for downloading files.

    You can manually select a different mirror (see https://wiki.qt.io/Online_Installer_4.x#Selecting_a_mirror_for_opensource ) -- run the installer from the Command Prompt to pass the --mirror argument.



  • Hi JKSH. Thanks. As it turned out, I gave up and went to bed, and in the morning, it magically started working - most likely, as you say, due to a bad mirror. If it hadn't worked, though, that link would have been my next step.

    If anyone who can do something about this is watching, it may be a good idea to link to https://wiki.qt.io/Online_Installer_4.x#Selecting_a_mirror_for_opensource from the download page, so people can easily find it when this apparently very common problem occurs.


Log in to reply