Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

ArcGIS SDK in linux with Qt opening only executable-shared library error



  • Hii.

    I have developed an application using ArcGIS with Qt. Application is running successfully with program in qt. But without using QT(or program), iam trying to run only executable. but it is throwing an error like shared library libesricommonqt.so. no such file or directory. i have pasted the libesricommonqt.so in the executable folder. but still exe not opening and throwing same error.

    Thanks in advance



  • @Jyothi
    You are supposed to use something like linuxdeployqt to install your executable, so that dependencies are dealt with.

    Try something like ldd libesricommonqt.so on that file in the executable folder to see if it has further dependencies which are missing. That can lead to the error message only complaining about libesricommonqt.so when there is an underlying error.



  • libesricommonqt.so depends on libruntimecore.so - please make sure both are in your LD_LIBRARY_PATH



  • hi,
    thanks for the reply. it is solved by linking the library through batch file.

    i have created one script(.sh) file and the file has the content as

    export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:./exe_folder_name/
    ./exe_folder_name/exe_name

    where, exe_folder_name contains the libraries to run application.

    now, simply run the above script file through command prompt.


Log in to reply