Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Unable to load QT environment



  • I'm at a complete loss and hoping someone can help. I'm used to the Visual Studio environment and setup, and QT is new to me. I'm running Linux Mint (debian 20.04) and installed qt5-default, and qtcreator. QT creator loaded fine the first time with no issues, however, after closing the application and a system reboot, it refuses to load. I've been scowering google and stack, I've found some similar issues but none of the solutions I've found so far have worked for me. Trying to run qtcreator from the terminal renders the following output:

    qtcreator: /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5: no version information available (required by qtcreator) qtcreator: /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5: no version information available (required by qtcreator) qtcreator: /usr/lib/x86_64-linux-gnu/libQt5Network.so.5: no version information available (required by qtcreator) qtcreator: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: no version information available (required by qtcreator) qtcreator: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: no version information available (required by qtcreator) qtcreator: /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5: no version information available (required by /usr/bin/../lib/x86_64-linux-gnu/qtcreator/libExtensionSystem.so.4) qtcreator: /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5: no version information available (required by /usr/bin/../lib/x86_64-linux-gnu/qtcreator/libExtensionSystem.so.4) qtcreator: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: no version information available (required by /usr/bin/../lib/x86_64-linux-gnu/qtcreator/libExtensionSystem.so.4) qtcreator: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: no version information available (required by /usr/bin/../lib/x86_64-linux-gnu/qtcreator/libExtensionSystem.so.4) qtcreator: /usr/lib/x86_64-linux-gnu/libQt5Xml.so.5: no version information available (required by /usr/bin/../lib/x86_64-linux-gnu/qtcreator/libUtils.so.4) qtcreator: /usr/lib/x86_64-linux-gnu/libQt5Network.so.5: no version information available (required by /usr/bin/../lib/x86_64-linux-gnu/qtcreator/libUtils.so.4) qtcreator: /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5: no version information available (required by /usr/bin/../lib/x86_64-linux-gnu/qtcreator/libUtils.so.4) qtcreator: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: no version information available (required by /usr/bin/../lib/x86_64-linux-gnu/qtcreator/libUtils.so.4) qtcreator: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: no version information available (required by /usr/bin/../lib/x86_64-linux-gnu/qtcreator/libUtils.so.4) qtcreator: /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5: no version information available (required by /usr/bin/../lib/x86_64-linux-gnu/qtcreator/libUtils.so.4) qtcreator: /usr/lib/x86_64-linux-gnu/libQt5Network.so.5: no version information available (required by /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5) qtcreator: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: no version information available (required by /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5) qtcreator: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: no version information available (required by /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5) qtcreator: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: no version information available (required by /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5) qtcreator: symbol lookup error: /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5: undefined symbol: _ZTI26QAbstractDynamicMetaObject, version Qt_5_PRIVATE_API

    Looking at qtchooser/default.conf file contains:
    /usr/lib/x86_64-linux-gnu/qt5/bin
    /usr/lib/x86_64-linux-gnu/qtcreator

    From the output, it would appear that there are two conflicting versions, however, being new to QT, I'm not exactly sure how or were I point it to the correct version. I appreciate any help!


  • Moderators

    So you have installed both with apt install right? If it does not work it's a bug in debian.

    I suggest this:

    • uninstall Qt Creator
    • use Qt online installer to install both Qt and Creator - as local user (not system-wide)

    This should work fine, will give you more flexibility, more frequent updates.


Log in to reply