Important: Please read the Qt Code of Conduct -

Qt VS Tools: Cannot set version.

  • Background:
    This was originally an old 32 bit VS2013/Qt5 project that I am trying to make a slight update to. Since VS2013 is no longer supported, I am opening it with VS2019. I have set %QT_DIR% to

    I navigate to Extensions->Qt VS Tools -> Qt Options and see the QT Versions field is blank. The pulldown for Default Qt/Win version is also empty. So If I click Add and set $(QTDIR) I see what looks like the correct path greyed out below. If I then click OK the default version is not added. If I try to manually set a path and version, the same thing occurs.

    If I right click on the Solution Explorer and choose Set Solution's Qt Version I see $(DefaultQtVersion) under installed Qt Versions. So I choose "Ok" to close the window and attempt to build.

    But "Build Solution" immediately throws an error dialog
    "The following error occured:"
    There's no Qt version assigned to project for configuration Debug/Win32.
    Please assign a Qt installation in "Qt Project Settings".

    Unfortunately, I am stuck here. Nothing else I have found online seems to help solve the problem. Why does attempting to set the version just not stick?

  • Lifetime Qt Champion

    Hi and welcome to the forums
    Vs 2013 is not compatible with 2019 so you need a new Qt too
    for Vs 2019.
    2015 and 2017 and 2019 is compatible but as far as I know
    2013 is not.

  • @mrjj Thanks for the prompt update. I am currently using VS2019, only the project file and parts that are shipped are VS2013 compatible for legal reasons. The project was originally built using VS2013 and Qt5.5.

    For the moment, I am just trying to get the original stuff to build and link properly.

  • Lifetime Qt Champion

    But the Qt5.5 will not work with VS2019 unless you have compiled
    Qt 5.5 yourself with vs2019.
    Qt is DLL based and VS2019 cannot load any DLLs made with Vs2013.
    So pointing it to C:\Qt\QT_MSVC2013\Qt\5.5
    will not work. Sorry.

Log in to reply