Missing QML components



  • Hi

    I'm trying to convert a Fremantel QWidget application to Harmattan QT Quick, but in the designer (in creator) I only have Basic, Positioners and Views tab !

    Shouldn't there be some components such as buttons etc ?

    I get the same result if I try to design for desktop or symbian !

    I'm using Ubuntu 11.10, and latest update of the SDK.

    Kim



  • is it possible to share the part of code which imports other components? maybe there's different between accessing paths on OS.



  • Hi

    This very simple code shows the problem :

    @import QtQuick 1.1
    import com.nokia.meego 1.0
    import QtQuick 1.0

    Page {
    id: page1
    tools: commonTools

    Button { id: button1; anchors.horizontalCenter: 
        parent.horizontalCenter; anchors.verticalCenter: 
        parent.verticalCenter}
    

    }@

    Button is known in the editor (it can list the properties), but when I open the designer I get the following :

    http://lpws.mine.nu/QTDesigner.png

    As shown here I only have the component pages basic, positioner and views, none of them contains a button.

    When I select button1 (as in this image) nothing is shown, this goes for all components, even those listed in the library section (some does show a blue rectangle where they should be).

    When I run the program in the simulator I do get an empty button centered on the display !

    Hope someone can help.

    Kim



  • Hi again

    After some tests, it semes as if qt-creator cannot find Qt.labs.components (imported in Button.qml), while the compiler can !

    Any idea why ?

    Kim


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.