Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Building Qt fails with missing dxgil_3.h



  • I'm trying to build qt-everywhere-src-5.14.2 on Windows 10 using MinGW.
    I get: fatal error: dxgi1_3.h: No such file or directory
    Seems the multimedia module is not successfully built.
    I'm building for DirectShow: Checking for DirectShow... yes
    What is this dxgi header and why is it missing - where can I get it?
    Sounds like a DirectX thing but I can not even find this in Windows SDK.

    g++ -c -include .pch\debug\qt_gui_pch.h -fno-keep-inline-dllexport -msse2 -mstackrealign -mfpmath=sse -g -Og -std=c++1y -ffunction-sections -fdata-sections -fno-exceptions -Wall -Wextra -Wextra -Wvla -Wdate-time -DUNICODE -D_UNICODE -DWIN32 -DMINGW_HAS_SECURE_API=1 -DQT_STATIC_BUILD -DWINVER=0x0601 -D_WIN32_WINNT=0x0601 -DQT_NO_LINKED_LIST -DQT_NO_JAVA_STYLE_ITERATORS -DQT_NO_USING_NAMESPACE -DQT_NO_FOREACH -DMD4C_USE_UTF8 -DQT_NO_NARROWING_CONVERSIONS_IN_CONNECT -DQT_BUILD_GUI_LIB -DQT_BUILDING_QT -D_CRT_SECURE_NO_WARNINGS -D_USE_MATH_DEFINES -DQT_NO_CAST_TO_ASCII -DQT_ASCII_CAST_WARNINGS -DQT_MOC_COMPAT -DQT_USE_QSTRINGBUILDER -DQT_DEPRECATED_WARNINGS -DQT_DISABLE_DEPRECATED_B
    EFORE=0x040800 -DQT_DEPRECATED_WARNINGS_SINCE=0x060000 -DQT_CORE_LIB -DQT_CORE_LIB -DQT_NO_EXCEPTIONS -I. -I..\3rdparty\md4c -I..\3rdparty\zlib\src -I..\3rdparty\VulkanMemoryAllocator -I....\include -I....\include\QtGui -I....
    \include\QtGui\5.14.2 -I....\include\QtGui\5.14.2\QtGui -Itmp -I.tracegen\debug -I....\include\QtCore\5.14.2 -I....\include\QtCore\5.14.2\QtCore -I....\include\QtCore -I.moc\debug -I..\3rdparty\libpng -I..\3rdparty\harfbuzz-ng\include -I....\mkspecs\win32-g++ -o .obj\debug\qtextdocument_p.o text\qtextdocument_p.cpp

    In file included from rhi\qrhi.cpp:49:0:
    rhi\qrhid3d11_p_p.h:57:21: fatal error: dxgi1_3.h: No such file or directory
    compilation terminated.
    Makefile.Release:73395: recipe for target '.obj/release/qrhi.o' failed
    mingw32-make[4]: *** [.obj/release/qrhi.o] Error 1



  • Were you able to resolve this issue? I just tried to build Qt 5.15 (skipped the 5.14 releases) and bumped into the same error.

    Any hint of where to look would be much appreciated.


Log in to reply