Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

QML and QT Quick error



  • Hi all . I hope you are well. I am not. I started with Qt not long ago and for a week I have decided to get into Qt Quick and QML and each time I create a project I get an error: Qt Quick emulation layer crashed. (Line 1) .. please need help i don't know why i got this error i'm using Qt 5.14.1 on windows



  • @Lelouche

    Hi and welcome to devnet forum

    Similar as to your previous question you need to give more information about your actual problem.
    What compiler are you using?
    Also it would help to provide source causing the problem.



  • @koahnig
    I use MinGw32_bits



  • @koahnig
    after creating the Quick project everything goes well I compile perfectly but when I enter the designer for the design I receive an error in line 1 of the .qml file suddenly.
    error: Qt Quick emulation layer crashed:( Line :1)



  • @Lelouche

    Which of the default projects are using?

    I have created the stack qt quick project and I can open the designer with the qml.

    Which version of Qt creator are you using?



  • @koahnig
    I use Qt 5.14.1



  • @Lelouche

    Are you using Qt creator as development environment?



  • @koahnig
    I use QT Creator as a development environment. I installed the open source version ..
    sorry if i take a long time to answer just that i am new in the forum and i should only answer after every 10 minutes



  • @Lelouche

    Best is to create a new Qt Quick project. Compile and run as is to verify that it is properly created. Then try to use the designer on its .qml files. As indicated above, I have tried the application Stack
    5b928d37-b593-4171-883e-8483d6b9dc14-image.png

    It should work with this project.
    If not, you probably have a problem with your installation of Qt. Remove and reinstall the open source version completely.



  • @koahnig
    Hello since I read your message I try in wine to solve the problem but nothing. I use the emulation layer given by Qt nothing works I even use the puppet nothing always but in revenge I noticed that my path was empty in the .pro file. should i add some path? I am waiting for your response thank you



  • QML_Import parth and QML Designer import parth are empty



  • @Lelouche

    This is my automatically generated .pro file

    QT += quick
    
    CONFIG += c++11
    
    # The following define makes your compiler emit warnings if you use
    # any Qt feature that has been marked deprecated (the exact warnings
    # depend on your compiler). Refer to the documentation for the
    # deprecated API to know how to port your code away from it.
    DEFINES += QT_DEPRECATED_WARNINGS
    
    # You can also make your code fail to compile if it uses deprecated APIs.
    # In order to do so, uncomment the following line.
    # You can also select to disable deprecated APIs only up to a certain version of Qt.
    #DEFINES += QT_DISABLE_DEPRECATED_BEFORE=0x060000    # disables all the APIs deprecated before Qt 6.0.0
    
    SOURCES += \
            main.cpp
    
    RESOURCES += qml.qrc
    
    # Additional import path used to resolve QML modules in Qt Creator's code model
    QML_IMPORT_PATH =
    
    # Additional import path used to resolve QML modules just for Qt Quick Designer
    QML_DESIGNER_IMPORT_PATH =
    
    # Default rules for deployment.
    qnx: target.path = /tmp/$${TARGET}/bin
    else: unix:!android: target.path = /opt/$${TARGET}/bin
    !isEmpty(target.path): INSTALLS += target
    

    Both settings are empty as well.

    b59d1757-9867-41d5-b448-26045016dbbd-image.png

    This above are my Qt creator settings for Qt Quick.

    At the moment I have no further idea of might be wrong with your setup.



  • @koahnig
    Hi you are doing well I hope it is exactly the same as at home but I do not understand why mine has problems .. you use the open source version?



  • @Lelouche

    Yes, Qt5.14.1 open source for MinGW 32bit in this case.



  • @koahnig
    Exactly the same thing as me but I do not know where there is the problem I will uninstall delete all related data and reinstall again. I'll let you know after that thank you



  • @koahnig
    Hello to everybody . I'm fine, I hope .I tried to do what you asked me to uninstall and reinstall but I still don't get a positive result. the problem can come from where please? then that I also use there towards Open Source and Mingw32 bits.



  • Good Morning everybody,

    I have the same Problem, with my QT...
    I also have QT 5.14.1, on my Windows 8.1 System..

    458340c3-adb2-46a4-8f14-e1b1559c573c-image.png

    Have you already found a soltion or any other Ideas that i could try to fix this?

    Regards
    Maurice



  • @Maurice

    Hi and welcome to devnet forum

    Did you check already with a freshly through qt creator generated qml application?



  • Hey koahnig,

    thanks.

    I have been working with Qt 5.9.0 for a while but I've never really used the Designer in QtCreator.
    I wanted to try the Designer in 5.9 but that didn't work, with the same.
    So Yesterday I installed a completely fresh new Qt 5.14.1 with the online installer and I tried the "heartrate-game" and the "gallery" example but this didn't work either with. I compiled with msvc2015 64 bit and i can also start the example, but the designer doesn't work..

    I already tried with some other paths that i found as solution but nothing really fixed the problem.

    c94e0b50-4cfb-462a-a4ac-e44731ae5b03-image.png

    Thanks for you help.



  • @Maurice
    hi here. Since then I have not been able to solve this problem and my path is written in red like yours once I entered it. if someone could really help us please



  • 909d9929-b690-4ada-b4a9-dfbc29631f55-image.png

    That is in my creator. However, I do not think that I have ever touched the setting.



  • @koahnig !
    with me the second path is not empty it contains a path to the puppet. but whatever the path chosen I get the same error .. I uninstall reinstalled as you asked but nothing and I can not say that I have installation errors and then do the online installation I follow the procedure



  • I wonder if there is anything else to do that I don't know



  • @Lelouche said in QML and QT Quick error:

    @koahnig !
    with me the second path is not empty it contains a path to the puppet. but whatever the path chosen I get the same error .. I uninstall reinstalled as you asked but nothing and I can not say that I have installation errors and then do the online installation I follow the procedure

    Since it is not selected, I expect that it will not cause an issue. However, I have some problems with qml anyhow. :(



  • @koahnig
    where can the problem come from?



  • @Lelouche said in QML and QT Quick error:

    @koahnig
    where can the problem come from?

    Unfortunately no glue.
    I started not long ago with qml and ran in a lot of issues. However, most of it is probably related to me. Did not get the concept yet.
    There are some issues with qml debugging, but I hesitate to reinstall, because this will probably also break what is currently still running.



  • Hey,

    sorry, i haven't been online for a while...
    I still haven't fixed the problem... but I found some hints, that it could be a problem with different QT version installed on one system... but i have no idea where the qt versions coul'd be mixed, because each one should have an own qml layer (i guess).
    At the moment I'm setting up a complete new system and I'll try if i have the same issue there.
    As soon as i know something, I'll let you know.



  • Okay, I have installed the QT on a fresh Windows and over there it's working....
    I guess somehow the versions are mixed up on my develope System, even everything is installed in different folders.



  • @Maurice

    Most likely something set in the environment. At least a good place for check. Have you added some of the folders to the PATH setting?



  • @koahnig
    not really... just some path settings for perl, VisualStudio etc. but nothing which points to a specific Qt Version.



  • I keep on getting this error message opening .qml files in the Designer inside Qt Creator: "Line: 1: Qt Quick emulation layer crashed."
    I tried all kinds of projects, even the simplest examples that come with Qt, like objectlistmodel, and I still get the error although I can compile and run them without any problem! I tried adding Style=Desktop to qtquickcontrols2.conf file but that didn't make a difference.
    I made my tests on two Windows 10 computers with Visual Studio 2019 installed. One of them had a fresh installation with only one version of Qt and Qt Creator, still had the error.
    Qt Creator versions 4.11, 4.12 RC, and 4.13 beta (?)
    Qt version 5.9, 5.11.3, 5.14, and 5.15 (I have some projects requiring specific Qt versions!)

    Any help would be appreciated


Log in to reply