Qt Oracle plugin with SDK 1.1.3



  • Hello to everyone :)

    Yesterday I downloaded the most recent Qt SDK (1.1.3) with Qt Creator 2.3 and all that stuff for Windows and was trying to create a simple Qt application that conects to a Oracle database. I read that I need to build the Oracle plugin (http://doc.qt.nokia.com/stable/sql-driver.html#qoci), basically it says something like this :

    set INCLUDE=%INCLUDE%;c:\oracle\oci\include
    set LIB=%LIB%;c:\oracle\oci\lib\msvc
    cd %QTDIR%\src\plugins\sqldrivers\oci
    qmake oci.pro
    nmake

    my problem is that I can not found the oci.pro file in my Qt installation...

    All i have is this path : C:\QtSDK\Desktop\Qt\4.7.4\msvc2008\plugins\sqldrivers

    but no src folder...

    Can someone please point me in the right direction to solve this? Do I need to update something? or install something else?

    Thanks in advance.

    Regards.

    [edit : moved to the installation subforum, Eddy]



  • You must choose QtSources from Qt SDK.
    Qt SDK-> Miscellaneous -> QtSources



  • Thanks cincirin I found the sorces where you indicated.

    Now I'm having another problem :S ...

    After running nmake I get the following error :

    main.cpp : fatal error C1902 Program database manager mismatch; please check your installation

    I have nno idea what this means

    Please Help!!



  • It's some microsoft weird compiler error. Try to google search to solve it. I found "Program database manager mismatch":http://social.msdn.microsoft.com/Forums/en/vcgeneral/thread/22a3cc87-7052-4ede-9a1b-81e49ab41d0d Seems to renaming mspdb80.dll from VC install/bin resolve the problem.
    But you can try other troubleshooting ...



  • Hi cincirin,

    After a lot of "googling" I managed to create qsqlocid4.dll an lib.

    One last question, how can I create the release versions?

    I suppose it's done with some flag or something, Can you please tell me which one?

    Thanks a lot. :)



  • Good to hear that. Would be better if you can tell how you solved the problem for other users to see.
    About the release version "see all commands line":http://www.qtcentre.org/wiki/index.php?title=Qt4_with_Visual_Studio#Release



  • Maybe there are other solutions, but the one that worked for me was the following:

    Copy : mspdb80.dll,
    mspdbcore.dll,
    msobj80.dll,
    mspdbsrv.exe

    From
    C:\Program Files (x86)\Microsoft Visual Studio 9.0\Common7\IDE
    to
    C:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\bin


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.