Planned maintenance has been done but it did not solve the problem. So work will continue on this and a new time for trying updates will be announced asap.

QT cannot create an AVD



  • So I have QT 5.13 installed on my Intel 64bit Windows 10 PC. I am using SDK Version: 26.1.1 and NDK Version: 19.2.5345600 with the JDK: jdk1.8.0_221.

    I can build for Android_for_x86_64_Clang just fine, however, when I go to run any project, it can't find a AVD to push it to. I have used Android Studio and created an AVD, but QT won't let me add it. It seems to work fine in Android Studio however.

    In QT debug window, the error I get is:

    Initializing deployment to Android device/simulator
    Error while building/deploying project chartthemes (kit: Android for x86_64 (Clang Qt 5.13.0 for Android x86_64))
    When executing step "Deploy to Android device"

    So when I select "Create Android Virtual Device" in the dialog box that comes up after hitting run, it says:

    Cannot create an AVD for ABI x86_64. Install an image for it.

    In Tools/Options, on the bottom, I go to Add under AVD Manager and it says the same thing. I click on Native AVD Manager and it says:

    AVD Manager UI Tool is not available in the installed SDK tools (version 26.1.1). Use the commandline tool "avdmanager" for advanced AVD management.

    However when I go to run avdmanager, nothing happens. It simply does not boot.

    How can I fix this and create an AVD to use with QT?



  • @the_dude said in QT cannot create an AVD:

    Cannot create an AVD for ABI x86_64. Install an image for it.

    Have you installed such image with Android SDK? See this answer (specially the screenshot there) to grab an idea of what could be missing from your installation...

    Use the commandline tool "avdmanager" for advanced AVD management

    Have you run it with -v switch for verbose mode? See avdmanager documentation just in case



  • @pablo-j-rogina I have run it with verbose mode, and it still didn't boot. Also, the answer you provided doesn't seem to link. Thanks for your reply! :-)


Log in to reply