Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Module is not installed error



  • Hello everyone!
    I need to have my own c++ module to be able to use it in .qml files. I create qml plugin (create project->library->qml plugin) with uri my_plugin. But when I try to install it (right click on project) that option is not available.
    Then I create qml application and put put “import my_plugin 1.0” in main.qml. It’s not underlined red and it’s building without any warnings. But when I run it:
    “Module my_plugin” is not installed.
    I’ve tried qt example of c++ extantion timer and I cannot import their module as well. They say run

    qmake
    make
    qmlscene -I import plugins.qml

    But last two don’t work (can’t find make)
    I try it on two different PCs. Result is exactly the same.
    I’m sitting on this for 2-3 days and tried every recepi I found: some people complain on it - but topics s 2-3 years old, and solutions is not detailed enough for me to understand and perform right.
    I’m pretty new at Qml and it seems I miss some simple details. Thanks in advance for ANY help.