Gtk-CRITICAL error when attempting to install Qt



  • When I open the online installer of Qt I get the following error

    @(Qt_SDK_Lin64_online_v1_1_3_en.run:2471): Gtk-CRITICAL **: IA__gtk_widget_style_get: assertion `GTK_IS_WIDGET (widget)' failed@

    If I ignore the error and attempt to install Qt my entire computer completely locks up after specifying the install dir. I am running Ubuntu 11.10 64-bit.

    Any help would be much appreciated.



  • I have exactly the same problem except that I am running Ubuntu 11.10 32-bit not 64-bit.


  • Moderators

    I get lots of those Gtk-CRITICAL warnings when running any Gtk-based application from a terminal. I guess those are normal?

    Installation went smoothly for me (it currently is downloading the components). I am using Ubuntu 11.10 (64bit) with Gnome 3.2.



  • There are an other way to install it ?


  • Moderators

    Try installing while running some UI environment that is not unity (3D). A hard crash in Linux is nowadays most often caused by the graphics drivers and unity needs way more of those than others. Might be worth a try...




  • Moderators

    Wow, that is a really annoying bug they have there:-(

    Try switching the Qt4 theme using qt-config (no idea where that is included in ubuntu) or just switch the GTK theme to one not provided by canonical. That might already work around the problem. Let's hope ubuntu fixes this soon!



  • Hi,

    I'm having a similar problem when trying to install Qt on ubuntu 11.10. I tried on unity-2d and xubuntu desktops. The installer asks for type of installation (standard or custom), folder to install and then the computer almost hangs for several minutes. The installer still runs (the task bar icon is present) but when I click on it the computer hangs for several minutes, and nothing happens. When I run from the command line I get several identical error messages "Gtk_CRITICAL: IA_gtk_widgetstyle assertion GTK_IS_WIDGET".

    How do you change the QT4 theme using qt-config?

    I just noticed that Ubuntu software centre offers the option to install Qt-creator (and qt-others). I will try this route and see if I am successful.

    EDITED
    I can confirm that installation via ubuntu software centre was successful, the computer didn't hang up during the installation and the QtCreator program starts fine.





  • how to solve this problem ,

    does anybody have a clear way ?


  • Moderators

    dangcheng: Did you read the article Yordan Ivanov linked to?



  • [quote author="Tobias Hunger" date="1320491280"]dangcheng: Did you read the article Yordan Ivanov linked to?[/quote]

    yeah.
    but in ubuntu 11.10 still have problem

    I am using ubuntu 11.10 i follow Yordan guide like below:
    ./Qt_SDK_Lin32_offline_v1_1_1_en.run -style cleanlooks
    then error still :
    QCoreApplication::applicationFilePath: Please instantiate the QApplication object first
    Unknown option: -style
    could you help me ? thanks!



  • i also have the same problem too when i'm trying to install qt on my ubuntu 11.10. But i managed to install it using Ubuntu Software Center. Hope that helps.



  • same problem here except when i installed using ubuntu SC i don't get the full install of Qt SDK, some methods and functions seems to be missing.



  • The same problem!! tried every trick on the book! nothing worked (I'm running Ubuntu 12.04 :( )
    And tried that version on the software Center !! Well It's not that similar to the one I used on MAC or on Windows, and has loads of errors especially when "compiling" (to be fair; couldn't understand the errors given though the "code" is 101 % correct)
    I see that it'd started about a year ago, Linux didn't fix it; well !! Can we see an effort from Qt Team to fix that bug? If so, anytime sooner ?!! :(



  • I am on Ubuntu 12.04 ./QtSdk-offline-linux-x86_64-v1.2.1.run -style motif works fine for me. Without the style argument my computer freezes



  • [quote author="ryelluripati" date="1345181153"]I am on Ubuntu 12.04 ./QtSdk-offline-linux-x86_64-v1.2.1.run -style motif works fine for me. Without the style argument my computer freezes[/quote]

    Same with my Ubuntu 12.04. Thanks for hint!


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.