[Solved] Qt5 on linux arm - xcb platform plugin not working



  • Hi,

    I compiled Qt5 for arm based on these instructions:

    http://labs.qt.nokia.com/2011/10/03/chasing-the-raspberry-pi-dragon-opengl-es2-accelerated-qt-pi/

    And this is how I configured it:

    ./configure -opensource -arch arm -xplatform linux-g++-mx5x -release -opengl es2 -little-endian -nomake docs -no-svg -no-audio-backend -no-multimedia -no-xmlpatterns -no-v8 -no-location -no-declarative -no-cups -xcb -no-wayland -no-phonon -no-qt3support -no-webkit -no-javascript-jit -no-neon -confirm-license -verbose -qpa -no-gtkstyle

    After compiling and installing sucessfully, I try to run any example an get this:

    $./classwizard -platform xcb
    Failed to load platform plugin "xcb". Available platforms are:
    EglFS
    Minimal

    Aborted

    But if I list the plugins directory, there is indeed a xcb plugin:

    $ls /usr/local/Trolltech/QtLighthouse-5.0.0-arm/plugins/platforms
    libqeglfs.so libqminimal.so libxcb.so

    When I use the minimal plugin, it runs fine and generates a picture of what would be painted on the screen.
    When I compile for my desktop (64bits), the xcb plugin works fine.

    Does anyone know what I might be doing wrong? Does the xcb plugin work on arm?

    Thanks in advance for any help,

    Guilherme



  • Never mind, I solved the problem. There were some packages missing. Namely libx11-xcb1 and libx11-xcb-dev. I think it's just easier to install all packages mentioned in qtbase/src/plugins/platforms/xcb/README:

    On debian based systems:

    apt-get install libxcb1 libxcb1-dev libx11-xcb1 libx11-xcb-dev libxcb-keysyms1 libxcb-keysyms1-dev libxcb-image0 libxcb-image0-dev libxcb-shm0 libxcb-shm0-dev libxcb-icccm1 libxcb-icccm1-dev libxcb-sync0 libxcb-sync0-dev libxcb-render-util0 libxcb-render-util0-dev libxcb-xfixes0-dev



  • Hi, where did you get the linux-g++-mx5x compiler ? I get to following error:

    The specified system/compiler is not supported:

      */home/lucid/qt5/qtbase/mkspecs/linux-g++-mx5x*


  • Hi, Saddan,

    How you used

    @-little-endian@

    in the QT 5 configure? I also tried the same but got error that @-little-endian@
    is unrecognized switch.

    Kindly provide information.

    Thanks


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.