Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

No text or label displayed



  • Re: Cross compile dont gen QLabel and QPushbutton and Fontconfig pre-condition

    I get same kind of issue as described in previous post. Qt is not able to display any text/label whereas windows and controls display well...
    My arch is ARM64-Zync (from Xilinx) under Linux. I tried many Qt versions (5.10, 5.7, 5.6, 5.3) that I cross-compiled but issue is the same... I also tried different plugins (linufb, xcb) without success. Qt apps/plugins don't return any error. Everything seems to work well... The only error messages I get are from X11 when using xcb plugin :
    XmbTextListToTextProperty result code -2
    If I run my Qt apps under a Linux distro provided by Xilinx (with pre-compiled librairies), it works well. If I run the same apps under a Linux distro generated by myself (with Xilinx PetaLinux Yocto tools), it doesn't work, even if I use all the pre-compiled Qt librairies (and so on) extracted from the Linux distro provided by Xilinx !

    Any idea to solve this ?

    Tnx


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Did you compare the Qt related content of both the Xilinx provided and your distribution ? For example do you have fontconfig on both systems ? Do you have fonts installed ? etc.



  • @SGaist said in No text or label displayed:

    fontconfig on both systems

    Hi SGaist,

    Thanks for your quick reply !
    As you suggested, I compared the /usr/share directory of my 2 distros and indeed /usr/share/fonts was missing in the faulty one...
    What is a bit surprising is that Qt don't shout if it don't find any font on the system...

    Best Regards


  • Lifetime Qt Champion

    Empty folder and missing folder are two different use cases. The first one might not trigger the same code path.

    [edit: fixed wrong answer SGaist]



  • @lacoudou said in No text or label displayed:

    indeed /usr/share/fonts was missing in the faulty one...

    So is your issue solved? If yes, please don't forget to mark your post as such.



  • @SGaist Sure, but the final status is the same from the point of view of the Qt app: Not able to display any text...
    Anyway, thanks for your help !


Log in to reply