Error building Qt app for Android with Qt Creator - installed SDK tools version (26.1.1) does not include Gradle scripts



  • Hi,

    When I tried to build QtFireExample with my QtCreator, failed with below error message.

    The installed SDK tools version (26.1.1) does not include Gradle scripts. The minimum Qt version required for Gradle build to work is 5.9.0/5.6.3 Error while building/deploying project QtFirebaseExample (kit: Android) When executing step "Build Android APK"

    My android studio is 3.2.1. And SDK tools 26.1 is also installed.
    qt version is also above 5.9.0
    What I did mistake?

    ❯ qmake --version
    QMake version 3.1
    Using Qt version 5.12.0 in /usr/local/Cellar/qt/5.12.0/lib


  • Qt Champions 2018

    @Sungyong You should install Gradle as well. I'm not sure but doesn't QtCreator ask you to do so (or maybe it was Android Studio where I saw it).



  • @jsulm Thank you for your answer.
    As your advice, I installed newest gradle which has version 5.1.
    But still build failed with same message. Do you have any idea?

    ❯ gradle -version

    Welcome to Gradle 5.1!

    Here are the highlights of this release:

    • Control which dependencies can be retrieved from which repositories
    • Production-ready configuration avoidance APIs

    For more details see https://docs.gradle.org/5.1/release-notes.html


    Gradle 5.1

    Build time: 2019-01-02 18:57:47 UTC
    Revision: d09c2e354576ac41078c322815cc6db2b66d976e

    Kotlin DSL: 1.1.0
    Kotlin: 1.3.11
    Groovy: 2.5.4
    Ant: Apache Ant(TM) version 1.9.13 compiled on July 10 2018
    JVM: 1.8.0_191 (Oracle Corporation 25.191-b12)
    OS: Mac OS X 10.14.2 x86_64


  • Qt Champions 2018

    @Sungyong You should install Gradle through QtCreator or (more likely, I'm not Android expert) through Android SDK.


  • Moderators

    @Sungyong
    what QtCreator version are you using?
    Did you install the build-tools in your Android SDK Manager?



  • Thanks all for reply.

    @jsulm How can I install gRalde throught QtCreator?
    From Qt Document (http://doc.qt.io/qtcreator/creator-developing-android.html), it says as below.
    Gradle is delivered with Qt 5.9, and later. Because Gradle scripts are not delivered with Android SDK Tools since version 26.0.0, they are delivered with Qt 5.9 and 5.6.3.

    @raven-worx
    My environments are below.

    MacOS 10.14.2
    Qt Creator 4.8.0
    Based on Qt 5.12.0 (Clang 10.0 (Apple), 64 bit
    Android Studio 3.2.1 (it includes SDK)

    • SDK Version: 26.1.1
    • NDK version: 16.1.4479499


  • @Sungyong I was stuck like you and finally found a workaround like this:

    Install "Android armV7" and "x86" with Qt MaintenanceTool (under Qt X version).
    Now you will see the two kits added to QtCreator.
    I selected armV7 and build went fine.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.