Xcodebuild failed.



  • export TOOLCHAINS=
    /Applications/Xcode.app/Contents/Developer/usr/bin/copypng -compress -strip-PNG-text /Users/ME/Documents/Qt_PRJ/build-TEST_IOS-Qt_5_2_0_for_iOS_Simulator-Debug/TEST_IOS.xcodeproj/Default-568h@2x.png /Users/ME/Documents/Qt_PRJ/build-TEST_IOS-Qt_5_2_0_for_iOS_Simulator-Debug/Debug-iphonesimulator/TEST_IOS.app/Default-568h@2x.png
    

    error: can't exec '/Applications/Xcode.app/Contents/Developer/usr/bin/copypng' (Permission denied)
    Command /Applications/Xcode.app/Contents/Developer/usr/bin/copypng failed with exit code 71

    make[1]: *** [iphonesimulator-debug] Error 65
    make: *** [debug-iphonesimulator] Error 2
    21:13:13: The process "/usr/bin/make" exited with code 2.
    Error while building/deploying project TEST_IOS (kit: Qt 5.2.0 for iOS Simulator)
    The kit Qt 5.2.0 for iOS Simulator has configuration issues which might be the root cause for this problem.
    When executing step "Make"
    

    Someone can help me? I'm so tried! It's a week that i try to resolve it! Thank you!


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    What version of macOS are you running ?
    Which version of Xcode are you using ?
    Why are you using such an outdated version of Qt ?
    What are you using to build your application ?



  • @SGaist
    I use a macOS 10.13 and Xcode version 9.4.1
    I decided to use a version of Qt 5.2 beacause the latest versions take up a lot of space. I use a Debug iOS simulator. Do you think this problem could ne resolved with the latest version of Qt?


  • Moderators

    @edoardo.videx said in Xcodebuild failed.:

    beacause the latest versions take up a lot of space

    How much more space does Qt 5.11.1 consume compared to 5.2? Is your hard disk already full? I mean, this is really not a reason to use such an old Qt version. Especially if you're targeting mobile platforms.



  • @jsulm
    The difference between this two versions is 17Gb of memory



  • @edoardo.videx
    That is because you blindly selected everything from the installer.

    The online installer provides pre compiled libaries for 10ish different systems.

    Expand the tree and only select the one you actually want/need. The IOS precompiled libaries shouldn't take more than 2 gb of space.



  • Today i'll try and i let you know! Thank you!



  • @jsulm @J-Hilk I update Qt to 5.11 and i've the same problem.

    ** BUILD FAILED **

    The following build commands failed:
    CopyPNGFile Debug-iphonesimulator/TEST_IOS.app/Default-568h@2x.png TEST_IOS.xcodeproj/Default-568h@2x.png
    (1 failure)
    make: *** [xcodebuild-debug-simulator] Error 65
    18:51:31: The process "/usr/bin/make" exited with code 2.
    Error while building/deploying project TEST_IOS (kit: Qt 5.11.1 for iOS Simulator)
    When executing step "Make"

    COMPILE OUTPUT:

    Accounts preference pane.
        -allowProvisioningDeviceRegistration                     Allow xcodebuild to register your destination device on the developer portal if necessary. This flag only takes effect if -allowProvisioningUpdates is also passed.
    Can't exec "": No such file or directory at /Applications/Xcode.app/Contents/Developer/usr/bin/copypng line 89.
    ERROR: Failed to run  -q -iphone -f 0 -rem text /Users/ME/Documents/Qt_PRJ/build-TEST_IOS-Qt_5_11_1_for_iOS_Simulator-Debug/TEST_IOS.xcodeproj/Default-568h@2x.png /Users/ME/Documents/Qt_PRJ/build-TEST_IOS-Qt_5_11_1_for_iOS_Simulator-Debug/Debug-iphonesimulator/TEST_IOS.app/Default-568h@2x.png
    Command /Applications/Xcode.app/Contents/Developer/usr/bin/copypng failed with exit code 255
    

    Please help me!



  • @edoardo.videx
    ok, first things first,
    do you have an ios developer account and is it registered/setup on your mac?



  • @J.Hilk Yes!



  • @edoardo.videx
    Did you register your target device in the Apple-Developer portal?



  • @J.Hilk
    How i do it?


  • Lifetime Qt Champion

    Did you once start Xcode itself to check that you have everything needed available ?



  • @SGaist
    Yes! I also start an example app. And everythings work!


  • Lifetime Qt Champion

    Did you update Qt in the interval ?
    The how are you setting up your project ?
    Are you compiling with QtCreator ?



  • I'm stuck with a similar problem after upgrading to macOS 10.13.6, XCode 9.4, running Qt5.6.2:

    CopyPNGFile Debug-iphoneos/CmsMobileApp.app/Icon-29.png /Users/appbuilder/Home/workspace/iOS-AutoRecloser3/appCMS_Mobile/CmsMobileApp/ios/Icon-29.png
        cd /Users/appbuilder/Home/workspace/iOS-AutoRecloser3/iosbuild/appCMS_Mobile/CmsMobileApp
        export DEVELOPER_DIR=/Applications/Xcode.app/Contents/Developer
        export PATH="/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/usr/bin:/Applications/Xcode.app/Contents/Developer/usr/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin;"
        export SDKROOT=/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS11.4.sdk
        export TOOLCHAINS=
        /Applications/Xcode.app/Contents/Developer/usr/bin/copypng -compress -strip-PNG-text /Users/appbuilder/Home/workspace/iOS-AutoRecloser3/appCMS_Mobile/CmsMobileApp/ios/Icon-29.png /Users/appbuilder/Home/workspace/iOS-AutoRecloser3/iosbuild/appCMS_Mobile/CmsMobileApp/Debug-iphoneos/CmsMobileApp.app/Icon-29.png
    xcrun: error: invalid option '-f'
    Usage: xcrun [-project <projectname>] [[-target <targetname>]...
    Can't exec "": No such file or directory at /Applications/Xcode.app/Contents/Developer/usr/bin/copypng line 89.
    ERROR: Failed to run  -q -iphone -f 0 -rem text /Users/appbuilder/Home/workspace/iOS-AutoRecloser3/appCMS_Mobile/CmsMobileApp/ios/Icon-29.png /Users/appbuilder/Home/workspace/iOS-AutoRecloser3/iosbuild/appCMS_Mobile/CmsMobileApp/Debug-iphoneos/CmsMobileApp.app/Icon-29.png
    Command /Applications/Xcode.app/Contents/Developer/usr/bin/copypng failed with exit code 255
    

    There were a few other issues related to recent update to the environment (development team, license agreement thing, sdk version check) which were solved apparently, but unfortunately can't find solution for the problem above. Tried as suggested in some places installing/reseting command line tools for xcode (current xcode-select version 2349), the issue persists. The same project can be built by xcode opening .xcodeproj generated by

    qmake -spec macx-xcode -r myproject.pro
    

    However, the following fails as shown above

    /$QMAKE ../$PROJECT_NAME.pro -r -spec macx-ios-clang CONFIG+=iphoneos QMAKE_MAC_XCODE_SETTINGS=team team.name=DEVELOPMENT_TEAM team.value=/$TEAMID
    

    Any advice will be very much appreciated!


  • Lifetime Qt Champion

    @ppnp, you might want to check with a more recent version of Qt. If you need LTS, then 5.9 is the current one.



  • @SGaist, thanks. Due to license terms Qt5.6.2 is the latest available for the time being. Fortunately, re-install of Xcode app fixed the issue for me. Cheers!


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.