Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

he OpenGL ES 2.0 functionality test failed!



  • On Ubuntu 16.0.4 / with Qt 5.4 trying to build raspberry Pi Cross compiler
    following https://wiki.qt.io/RaspberryPi2EGLFS

    • after giving command
      sudo ./configure -opengl es2 -device linux-rasp-pi-g++ -device-option CROSS_COMPILE=$RPI_TOOLCHAIN -sysroot $RPI_SYSROOT -opensource -confirm-license -optimized-qmake -reduce-exports -release -make libs -prefix /usr/local/qt5pi -skip qtwebkit

    You might need to modify the include and library search paths by editing
    QMAKE_INCDIR_OPENGL_ES2, QMAKE_LIBDIR_OPENGL_ES2 and
    QMAKE_LIBS_OPENGL_ES2 in
    /opt/Qt/5.4/Src/qtbase/mkspecs/devices/linux-rasp-pi-g++.
    sudhir@PCSPL:/opt/Qt/5.4/Src$ sudo apt-get install mesa-common-dev


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Add the -v option to get more information about why the test fails.

    On a side note, you should avoid building stuff as root using sudo.


Log in to reply