Planned maintenance has been done but it did not solve the problem. So work will continue on this and a new time for trying updates will be announced asap.

qtbase compilation error : mkspecs/devices/linux-imx6-g++/qeglfshooks_imx6.cpp': No such file or directory



  • Hi All,
    I am trying to add Qt to our embedded device. using meta-qt5 layer with qt version of 5.10.1. for qtbase i am getting this error
    cp: cannot stat '/home/anjo/eliu_accs/eliu_accs/src/build/tmp/work/cortexa9hf-vfp-neon-mx6qdl-poky-linux-gnueabi/qtbase/5.10.1+gitAUTOINC+6c6ace9d23-r0/git/mkspecs/devices/linux-imx6-g++/qeglfshooks_imx6.cpp': No such file or directory
    But this file qeglfshooks_imx6.cpp isn't present in any of the qtbase revision from 5.5. i have tried versions 5.5, 5.9 and 5.10. all giving same error. my device is imx6 based and i am going to use eglfs as platform . Is i am missing any configuration ?
    if i manually add the file "qeglfshooks_imx6.cpp" from some old repository it's giving me more error.
    Any help is appreciated

    Thanks



  • Are you using which Yocto branch?
    Could you tell the MACHINE and the bblayers you're using?