C1083 - Visual Studio 2015 standard headers aren't detected



  • I have installed the Qt Creator with MSVC2015 - 64bits with VS2015 Community.

    The project refuses to compile and I added pretty much every directory that I can think of to the system environment variables to make it work but it refuses to detect headers like type_traits, math.h, vector, etc.

    I know that those headers are in the Windows SDK and some in the VS 14.0 VC includes and i've added all those paths. I've installed and uninstalled everything and yet it still doesn't find headers.

    0_1517329962024_ErreursCompilation2.PNG
    0_1517330073769_Environnement.PNG

    0_1517330289598_Kit.PNG

    I should point out that i'm using Qt 5.9.1 and I should also point out that the Qt version and Visual Studio version can't be changed(not that they should) because they were mandated from the dev team for this project, so I can't really divert.

    I have tried to fix this for several days now and I would appreciate any help that you could provide.

    Thank you very much.


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    There's something fishy: the error shows this ÿ char. Did you check the content of qglobal.h ? Whether there some stray char in it ?



  • Hi there, thank you for the warm welcome.

    I looked in qglobal.h and the ÿ character seems to represent the <> around the libraries but isn't that how you're supposed to call it?

    0_1517406329959_typetrait.PNG

    Thank you for your swift responses.



  • Important to note that I did not have those stray characters when I installed Qt in english, but my system is in french. Even then, I had the errors minus the ÿ.



  • Just an update, switched the system to english to show that it's just a language error0_1517428943985_typetrait_eng.PNG


  • Lifetime Qt Champion

    Can you show your .pro file ?



  • Hello there,

    sorry I was away from the office yesterday. Here is the .pro file
    0_1517578924039_proFile.PNG


  • Lifetime Qt Champion

    AFAIK, the SUBDIRS should only contain folders.

    By the way, can you build a default application ?



  • Hello there, I just made a default widget application and got the same errors.

    .pro file for default app:

    0_1517835982737_.proTestFile.PNG

    errors:
    0_1517835987488_errorTestApplication.PNG

    It does seem like Qt or my system can't detect where the Visual Studio 2015 headers are located. At this point, I'm considering just doing a fresh reinstall of this computer's OS.

    Thank you in advance.



  • @jBesserer said in C1083 - Visual Studio 2015 standard headers aren't detected:

    At this point, I'm considering just doing a fresh reinstall of this computer's OS.

    Before you do this, please show us the messages from the "Compile Output" pane when you re-build the minimal example (Please insert as text here).



  • Here you go, sir.
    08:17:29: Running steps for project testApplication...
    08:17:29: Starting: "C:\Qt\Tools\QtCreator\bin\jom.exe" clean
    C:\Qt\Tools\QtCreator\bin\jom.exe -f Makefile.Debug clean
    del debug\moc_predefs.h
    del debug\moc_mainwindow.cpp
    del ui_mainwindow.h
    del debug\main.obj debug\mainwindow.obj debug\moc_mainwindow.obj
    Could Not Find C:\Users\BESJ2703\Documents\build-testApplication-Desktop_Qt_5_9_1_MSVC2015_64bit-Debug\debug\main.obj
    del debug\testApplication.exp debug\testApplication.vc.pdb debug\testApplication.ilk debug\testApplication.idb
    C:\Qt\Tools\QtCreator\bin\jom.exe -f Makefile.Release clean
    del release\moc_predefs.h
    Could Not Find C:\Users\BESJ2703\Documents\build-testApplication-Desktop_Qt_5_9_1_MSVC2015_64bit-Debug\release\moc_predefs.h
    del release\moc_mainwindow.cpp
    del ui_mainwindow.h
    Could Not Find C:\Users\BESJ2703\Documents\build-testApplication-Desktop_Qt_5_9_1_MSVC2015_64bit-Debug\release\moc_mainwindow.cpp
    Could Not Find C:\Users\BESJ2703\Documents\build-testApplication-Desktop_Qt_5_9_1_MSVC2015_64bit-Debug\ui_mainwindow.h
    del release\main.obj release\mainwindow.obj release\moc_mainwindow.obj
    Could Not Find C:\Users\BESJ2703\Documents\build-testApplication-Desktop_Qt_5_9_1_MSVC2015_64bit-Debug\release\main.obj
    del release\testApplication.exp
    Could Not Find C:\Users\BESJ2703\Documents\build-testApplication-Desktop_Qt_5_9_1_MSVC2015_64bit-Debug\release\testApplication.exp
    del testApplication.exp
    Could Not Find C:\Users\BESJ2703\Documents\build-testApplication-Desktop_Qt_5_9_1_MSVC2015_64bit-Debug\testApplication.exp
    del testApplication.vc.pdb
    Could Not Find C:\Users\BESJ2703\Documents\build-testApplication-Desktop_Qt_5_9_1_MSVC2015_64bit-Debug\testApplication.vc.pdb
    del testApplication.ilk
    Could Not Find C:\Users\BESJ2703\Documents\build-testApplication-Desktop_Qt_5_9_1_MSVC2015_64bit-Debug\testApplication.ilk
    del testApplication.idb
    Could Not Find C:\Users\BESJ2703\Documents\build-testApplication-Desktop_Qt_5_9_1_MSVC2015_64bit-Debug\testApplication.idb
    08:17:30: The process "C:\Qt\Tools\QtCreator\bin\jom.exe" exited normally.
    08:17:30: Configuration unchanged, skipping qmake step.
    08:17:30: Starting: "C:\Qt\Tools\QtCreator\bin\jom.exe"
    C:\Qt\Tools\QtCreator\bin\jom.exe -f Makefile.Debug
    C:\Qt\5.9.1\msvc2015_64\bin\uic.exe ..\testApplication\mainwindow.ui -o ui_mainwindow.h
    cl -c -nologo -Zc:wchar_t -FS -Zc:rvalueCast -Zc:inline -Zc:strictStrings -Zc:throwingNew -Zi -MDd -W3 -w34100 -w34189 -w44996 -w44456 -w44457 -w44458 -wd4577 -wd4467 -EHsc /Fddebug\testApplication.vc.pdb -DUNICODE -DWIN32 -DWIN64 -DQT_DEPRECATED_WARNINGS -DQT_QML_DEBUG -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I..\testApplication -I. -I........\Qt\5.9.1\msvc2015_64\include -I........\Qt\5.9.1\msvc2015_64\include\QtWidgets -I........\Qt\5.9.1\msvc2015_64\include\QtGui -I........\Qt\5.9.1\msvc2015_64\include\QtANGLE -I........\Qt\5.9.1\msvc2015_64\include\QtCore -Idebug -I. -I........\Qt\5.9.1\msvc2015_64\mkspecs\win32-msvc -Fodebug\ @C:\Users\BESJ2703\AppData\Local\Temp\main.obj.11176.31.jom
    cl -BxC:\Qt\5.9.1\msvc2015_64\bin\qmake.exe -nologo -Zc:wchar_t -FS -Zc:rvalueCast -Zc:inline -Zc:strictStrings -Zc:throwingNew -Zi -MDd -W3 -w34100 -w34189 -w44996 -w44456 -w44457 -w44458 -wd4577 -wd4467 -E ........\Qt\5.9.1\msvc2015_64\mkspecs\features\data\dummy.cpp 2>NUL >debug\moc_predefs.h
    main.cpp
    C:\Qt\5.9.1\msvc2015_64\include\QtCore/qglobal.h(45): fatal error C1083: Cannot open include file: 'type_traits': No such file or directory
    cl -c -nologo -Zc:wchar_t -FS -Zc:rvalueCast -Zc:inline -Zc:strictStrings -Zc:throwingNew -Zi -MDd -W3 -w34100 -w34189 -w44996 -w44456 -w44457 -w44458 -wd4577 -wd4467 -EHsc /Fddebug\testApplication.vc.pdb -DUNICODE -DWIN32 -DWIN64 -DQT_DEPRECATED_WARNINGS -DQT_QML_DEBUG -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I..\testApplication -I. -I........\Qt\5.9.1\msvc2015_64\include -I........\Qt\5.9.1\msvc2015_64\include\QtWidgets -I........\Qt\5.9.1\msvc2015_64\include\QtGui -I........\Qt\5.9.1\msvc2015_64\include\QtANGLE -I........\Qt\5.9.1\msvc2015_64\include\QtCore -Idebug -I. -I........\Qt\5.9.1\msvc2015_64\mkspecs\win32-msvc -Fodebug\ @C:\Users\BESJ2703\AppData\Local\Temp\mainwindow.obj.11176.47.jom
    mainwindow.cpp
    C:\Qt\5.9.1\msvc2015_64\include\QtCore/qglobal.h(45): fatal error C1083: Cannot open include file: 'type_traits': No such file or directory
    jom: C:\Users\BESJ2703\Documents\build-testApplication-Desktop_Qt_5_9_1_MSVC2015_64bit-Debug\Makefile.Debug [debug\main.obj] Error 2
    jom: C:\Users\BESJ2703\Documents\build-testApplication-Desktop_Qt_5_9_1_MSVC2015_64bit-Debug\Makefile.Debug [debug\mainwindow.obj] Error 2
    jom: C:\Users\BESJ2703\Documents\build-testApplication-Desktop_Qt_5_9_1_MSVC2015_64bit-Debug\Makefile [debug] Error 2
    08:17:30: The process "C:\Qt\Tools\QtCreator\bin\jom.exe" exited with code 2.
    Error while building/deploying project testApplication (kit: Desktop Qt 5.9.1 MSVC2015 64bit)
    When executing step "Make"
    08:17:30: Elapsed time: 00:01.



  • @jBesserer said in C1083 - Visual Studio 2015 standard headers aren't detected:

    cl -c -nologo -Zc:wchar_t -FS -Zc:rvalueCast -Zc:inline -Zc:strictStrings -Zc:throwingNew -Zi -MDd -W3 -w34100 -w34189 -w44996 -w44456 -w44457 -w44458 -wd4577 -wd4467 -EHsc /Fddebug\testApplication.vc.pdb -DUNICODE -DWIN32 -DWIN64 -DQT_DEPRECATED_WARNINGS -DQT_QML_DEBUG -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I..\testApplication -I. -I........\Qt\5.9.1\msvc2015_64\include -I........\Qt\5.9.1\msvc2015_64\include\QtWidgets -I........\Qt\5.9.1\msvc2015_64\include\QtGui -I........\Qt\5.9.1\msvc2015_64\include\QtANGLE -I........\Qt\5.9.1\msvc2015_64\include\QtCore -Idebug -I. -I........\Qt\5.9.1\msvc2015_64\mkspecs\win32-msvc -Fodebug\

    Looking at your compiler call, I see that all includes are relative paths. I'm not sure this is related, but I have seen only absolute paths so far.

    Can you try to create a "Plain C++ Application" (in Creator: File -> New File or Project -> Non-Qt Project -> Plain C++ Application) and see if that compiles?



  • Hello there,

    I just did a reinstall of Windows and I did a plain C++ application as you suggested and I get this:

    0_1518012599808_errorTestC++.PNG



  • So nothing really changed, Qt still fails to detect any of the standard visual studio headers and given that i've been working on this for over 2 weeks. I'm starting to be rather irritated (sorry, just venting.)



  • On a side note, when I installed Visual Studio and Qt, when I tried to run the plain program, it just said 'cannot find 'cl' did you set up your environment?

    I might as well ask, is setting up my environment just going in my system environment variables and adding the path to my compiler ?

    0_1518014531769_systemEnvironment.PNG

    All I did was add the last two lines.

    I'm working on windows 10 also, if that does anything.



  • @jBesserer said in C1083 - Visual Studio 2015 standard headers aren't detected:

    On a side note, when I installed Visual Studio and Qt, when I tried to run the plain program, it just said 'cannot find 'cl' did you set up your environment?

    That seems to describe you problem more clearly. Adding paths to the environment will probably not help you.

    Have you checked QTCREATORBUG-17474?



  • Am I supposed to run vcvarsall in the cmd, I thought qt just did it when you start compiling. if I was to try it, what would be the syntax for the command?

    0_1518017681536_settings1.PNG
    0_1518017688053_settings2.PNG

    Here are my settings, I know the error says it has no path for the compiler but that was after I removed the 2 lines from my system environment variables.



  • Here is what I get when I run the command from the cmd
    0_1518017993155_commontools.PNG


  • Lifetime Qt Champion

    What if you start directly the command line through one of the shortcuts provided with Visual Studio ?



  • Here you go:

    0_1518018611214_commontools2.PNG



  • @jBesserer At least you have a hint now what could be the problem...


  • Lifetime Qt Champion

    Could be something like described here.



  • @aha_1980 I would like to share your optimism, but I mostly don't understand anything from the answers to 'fix' this problem. As soon as we go into cmd or system32 related things I lose track of where to go and what to do because I can't conceptualize how to fix it.



  • @SGaist I already explored that possibility some days ago, but I have the system32 path in my system environment variables



  • @jBesserer So what happens if you enter reg in a Command Prompt?

    Can you show us the contentes of your PATH variable? (as text please).

    Sometimes windows has problems traversing the PATH if it contains an invalid directory.



  • @aha_1980 Here you go.

    0_1518019907000_regPath.PNG

    C:\Python27;C:\PCI Geomatics\Geomatica 2015\exe;%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;%SYSTEMROOT%\System32\WindowsPowerShell\v1.0;c:\MATLAB\R2016a\bin;%USERPROFILE%.dnx\bin;C:\Program Files\Microsoft DNX\Dnvm;C:\Program Files\Microsoft SQL Server\130\Tools\Binn;C:\Program Files (x86)\Windows Kits\10\Windows Performance Toolkit;C:\Program Files\TortoiseSVN\bin;C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\



  • In a different vein, it is okay if Visual Studio installed 2 different versions of the 2015 redist for (x64) ? Could that also cause a conflict?

    0_1518021600445_redists.PNG



  • @jBesserer: Is it correct that you used the "Cross Tools" Command Prompt?

    In a different vein, it is okay if Visual Studio installed 2 different versions of the 2015 redist for (x64) ? Could that also cause a conflict?

    Honestly, I don't know. The only tip I can give you is to debug the vcvars.bat and maybe ask for help in a Visual Studio forum. As the reg command is available for you, it must be something else that disallows your compiler usage.



  • @jBesserer: I just have another idea.

    On http://www.randygaul.net/2016/06/03/faster-vcvars32-bat is a description on how to speed up the vcvars32.bit.

    As the essence, he describes the variables that are set by this batch file. Maybe doing it like him gives you a running Visual Studio prompt that can also be used from Creator.



  • @aha_1980 I used the cross tool because i'm building with the x86_amd64 compiler in Qt...So I assumed that was how to do it. I don't really know.



  • @jBesserer said in C1083 - Visual Studio 2015 standard headers aren't detected:

    @aha_1980 I used the cross tool because i'm building with the x86_amd64 compiler in Qt...

    I'm confused too. if you have a 64 bit OS and want to create 64 bit apps then you don't cross compile...

    I cannot help further here, don't have Windows and no MSVC. Maybe someone else can. Sorry.



  • @aha_1980 Thank you very much for your earnest efforts in helping. :) I'm pretty much starting to assume that this is an internal network or user properties because when I try to install it anywhere at the University (my internship location) it doesn't compile and has always the same errors, but when I install it on my personal laptop and personal desktop, it compiles perfectly.

    I looked around everywhere and compared left and right, but I couldn't find an answer. I wanted to just install a VM on work computer yesterday but vt-x is disabled in the BIOS and the university's admin added a admin password to the BIOS, so i'm pretty much out of options.


  • Lifetime Qt Champion

    In that case, did you try to ask your university IT folks ?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.