Suddenly asking for access to SD card on Android 7.0


  • Moderators

    I have an application compiled for Android. The application is copied to my phone, which allows an installation from "unknown sources". Suddenly the application was not starting completely anymore, but apparently crashed. This was basically from one hour to the next.

    I checked it briefly and reinstalled, but the installation process on Android 7.0 (Nougat) asks now for permission to access SD card for read/write or read only access. Whatever I choose, the install button is not activated. I do not have an SD card in my phone.

    The recompilation has been tested Android 4.2 (API 17) and Android 7.0 (API 24) in both cases the same question during installation on Android 7.0.

    I reinstalled the application on Android 5.0 (obviously only the API 14 version) and there is no issue. The app may be installed without additional permission and it runs perfectly.

    Anyone an idea what might have happened?

    In the manifest file for no additional permissions is asked for.
    Is there a way to exclude asking for SD card access?


  • Moderators

    The issue has to do with the way to install my application. The application has been installed directly through AirDroid when the message came. After organizing a fitting SD card the issue remained.

    A slightly different installation process through copying to the internal memory and installation worked on Android 8, this has been verified with Android 7 and worked too.

    The final test to install without additional SD card by copying to internal memory and installing from there does also.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.