Unable to cross-compile using Qtcreator



  • I am trying to use poky cross-compiler in qtcreator to cross-compile application for Rensas Board.

    In qtcreator.sh
    i added :
    source /opt/poky/1.6.1/environment-setup-cortexa15hf-vfp-neon-poky-linux-gnueabi
    in qtcreator
    qmake path is /opt/poky/1.6.1/sysroots/i686-pokysdk-linux/usr/bin/qt5/qmake
    compiler path is /opt/poky/1.6.1/sysroots/i686-pokysdk-linux/usr/bin/arm-poky-linux-gnueabi/arm-poky-linux-gnueabi-gcc

    when i build my application i get
    linux-oe-g++ missing

    Again i manually did source /opt/poky/1.6.1/environment-setup-cortexa15hf-vfp-neon-poky-linux-gnueabi
    then i ran qtcreator.sh
    keeping all the settings same for qmake and compiler.
    this time i got
    QT version invalid , run make install.

    Kindly provide some solution.


  • Moderators

    @Sumit You should set g++ not gcc as compiler



  • @jsulm with g++ also i am facing the same problem.


  • Moderators

    @Sumit "QT version invalid , run make install" - did you install Qt?



  • @jsulm Yes i had installed that , please see the below log:

    administrator@administrator-OptiPlex-990:~$ sudo apt-get install qt5-default
    [sudo] password for administrator:
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    qt5-default is already the newest version.
    The following packages were automatically installed and are no longer required:
    libbonobo2-0 libbonobo2-common libgconf2-4 libgnome2-0 libgnome2-bin
    libgnome2-common libgnomevfs2-0 libgnomevfs2-common libidl-common libidl0
    liborbit-2-0 liborbit2
    Use 'apt-get autoremove' to remove them.
    0 upgraded, 0 newly installed, 0 to remove and 8 not upgraded.

    For building qt in Yocto Project i did :
    bitbake meta-toolcahin-qt

    is it something related to that.

    As i read, meta-toolchain-qt installs qt4.8. And the qmake which i am linking is from qt5 is that causing a problem?


  • Moderators

    @Sumit "meta-toolchain-qt installs qt4.8. And the qmake which i am linking is from qt5 is that causing a problem?" - yes it is. You need to use qmake from the Qt version you want to use and this Qt version must be installed (not only qmake).



  • @jsulm Thanks i will get back to you on this, once done.



  • @jsulm i got stuck while doing bitbake meta-tolchain-qt5.

    Error is:
    tmp/work/cortexa7hf-neon-vfpv4-poky-linux-gnueabi/qtbase/5.7.0+gitAUTOINC+69b43e74d7-r0/git/mkspecs/oe-device-extra.pri:
    No such file or directory

    Error 2: oe-runmake failed.

    For error 1:
    I found a patch which avoids this error by installing a qmake under mkspecs folder.
    But did not install linux-oe-g++ related files under mkspecs which will be further required by the Qtcreator to perform qmake and cross-sompile the application.

    If I use the above patch which avoids the Error 1, but Error 2 still persist(Somewhere it explains qmake version mismatch). There are some patch available to solve Error 2 .

    I am confused wether to skip the linux-oe-g++(which i think should not be) or install.



  • @jsulm it was the problem of qt version. I solved it by using bitbake meta-toolchain-qt5. Is there any way to have a SDK both with qt and opencv?


  • Moderators

    @Sumit I don't know. Who is providing the SDK?



  • @jsulm I will again rephrase my question. After bitbake meta-toolchain-qt5 i have a sdk which compiles qt files. Now if i add opencv libraries onto my image. I would need a sdk to compile opencv codes. So is there anyway to built same sdk both for qt and opencv. Or i have to use seperate sdk for opencv.


  • Moderators

    @Sumit Should be possible, but I never used Bitbake


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.