qt virtual keyboard not loading with armeabi v-7a



  • I am trying to use the virtual keyboard for the first time in an app, so after reading through the appropriate docs, I called the QT_IM_MODULE in main like so:

    qputenv("QT_IM_MODULE", QByteArray("qtvirtualkeyboard")); 
    

    In QML, I import:

    import QtQuick.VirtualKeyboard 2.0
    

    then instatiate an InputPanel and everything is wonderful when using minGW5.3 for my desktop build. But as soon as I switch my to my android kit armeabi v-7a
    I get error: module "QtQuick.VirtualKeyboard" is not installed and red line under
    the import..

    In the docs I did see that there are 2 ways to load the plugin, the one in main that works for me and another:

    $ QT_IM_MODULE=qtvirtualkeyboard myapp
    

    But I had no luck with this, I had tried to add it to the .pro but was a fail..
    I think this is the problem, but not sure how to fix it.

    Thanks for any help


  • Lifetime Qt Champion

    Hi,

    What version of Qt are you using ? How did you build it ? On what platform are you running ?



  • Hi!

    I'm using Qt 5.8 on windows 10, and I did not build it myself, just used the unified installer...

    thanks


  • Lifetime Qt Champion

    What is your target then ? ARM is an architecture not a platform per se so you need to give more details about that matter.



  • Oh ok, at the moment that would be api 20, just for testing purposes, shadow build
    is on, and Qt deployment is set to Bundle Qt libraries into APK. (if that helps)

    And I'm also using the latest JDK, Android SDK, Android NDK, and Apache Ant files.

    Let me know if you need anything else..

    thanks


  • Lifetime Qt Champion

    See this wiki entry about the known issues with the Android SDK.



  • Hi thanks for the wiki

    Thats just great. More bugs! I was aware of one that meant that the latest Android SDK tools had to be replaced with 25.2.5 tools (which it is what I had done before this keyboard issue) or Android just won't build... so my SDK was ok.

    After looking at your wiki post, and realising there are even more bugs, I also downgraded my latest NDK from r14b to r10e. Still no luck. If this can't be fixed then I may have to look into alternatives as it is driving me nuts.. Maliit may be an option, or making it myself, but I would rather use Qt's keyboard. So annoying...



  • Actually I've found what I was looking for and it was right under my nose... I didn't need qt virtual keyboard at all for android (thank god), I just needed a TextField. Not as pretty but works good enough for me!

    @SGaist Thanks for your assistance anyway. :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.